Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


sinister

Budding Enthusiast
  • Content count

    11
  • Joined

  • Last visited

About sinister

  • Rank
    Member

Contact Methods

  • First Name
    Andy

Profile Information

  • Gender*
    Male
  • Ford Model
    Focus
  • Ford Year
    2008
  • UK/Ireland Location
    Wiltshire
  • Annual Mileage
    10,001 to 15,000
  • Interests
    Classic Cars
    General Automotive
    Motorsport & Racing
    Car Restoration
    Car Modification
    Computers & Electronics
  1. I bought a Mk3 Mondeo one off of Ebay and fitted it to my '08 focus estate. Just need to be careful when cutting the roof liner, start small and enlarge the hole until it fits. You also need to taper the edge at the rear of the new hole so that the 2 parts clip together. And before anyone asks, no i didn't take any photos of the fitting process. (total focus on NOT wrecking the roof liner. Nothing else mattered).
  2. This does work. I have one fitted to my front courtesy light. With regard to what Artscot79 said about the resistor getting hot , it does, but i managed to get the resistor part outside the light unit so that it was between the roof and headlining. Been fitted nearly 2 years now and i've had no problems at all.
  3. To prevent the LED afterglow fit one of these: http://www.ebay.co.uk/itm/2x-LED-5W-SIDE-LIGHT-LOAD-RESISTOR-NO-ERROR-501-W5W-T10-/300593415079?pt=UK_CarsParts_Vehicles_CarParts_SM&hash=item45fcc383a7
  4. To anyone who has fitted one of these, how does yours power up? I have one that looks the same as the ones shown but not purchased from the same place, and it will only power up with the ignition at position 2 i.e all dash lights illuminated. Are yours the same or is there a way around this? Ideally i would like it to power on at position 1 or even without the key in (as the original did). Sorry for the thread hijack.
  5. If its more light you are after have a look at the link below. http://www.ebay.co.u...=item484bdfba1e I have 2 of these fitted in the front light and 2 fitted in the rear and 1 in each of the footwell lights. They are nice and bright and give off a good spread of light.
  6. I have changed both front and rear interior lights to LED's . To prevent the LED's from glowing in the front light i used one of these: http://www.ebay.co.uk/itm/2x-LED-5W-SIDE-LIGHT-LOAD-RESISTOR-NO-ERROR-501-W5W-T10-/300593415079?pt=UK_CarsParts_Vehicles_CarParts_SM&hash=item45fcc383a7 Plug one end into the lamp socket and the LED into the other end. Job done and no afterglow.
  7. To prevent the LED's from glowing in my centre light i used one of these: http://www.ebay.co.uk/itm/2-x-LED-501-T10-W5W-WEDGE-CANBUS-NO-ERROR-LOAD-RESISTOR-/300590337115?pt=UK_CarsParts_Vehicles_CarParts_SM&hash=item45fc948c5b Plug one end into the lamp socket and the LED into the other end. Job done and no afterglow.
  8. If anyone needs them here are the measurements for the wipers: Original metal one: 355mm (14") overall length. Blade length 280mm (11") Mondeo smooth with flat blade: 395mm (15.5") overall length. Blade length is the same as above. Hope this helps anyone looking to change
  9. If memory serves me correctly its slightly longer than the original but theres no fouling on anything as it sweeps
  10. If its any help i fitted one of these to my 2008 estate. http://www.ebay.co.uk/itm/FORD-MONDEO-ESTATE-FLAT-REAR-WIPER-ARM-BLADE-2002-2008-/140727940123?pt=UK_CarsParts_Vehicles_CarParts_SM&hash=item20c409f41b I know it's for a Mondeo but it fits and works a treat and being an aero type blade it matches the front
  11. I noticed this exact problem on my 08 focus not long after buying it. The way i found, to stop the date and/or time randomly changing, was to set the date and time from the drivers info panel and NOT on the radio itself. So far this has worked.(for me anyway).