• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


fez2i

Budding Enthusiast
  • Content count

    8
  • Joined

  • Last visited

About fez2i

  • Rank
    Newbie
  • Birthday 07/26/1983

Contact Methods

  • MSN
    badnews3@hotmail.co.uk
  • ICQ
    0

Profile Information

  • Gender*
    Male
  • Ford Model
    1993 xr2i 16v 150 bhp
  1. Odd noise when pulling away

    check if it does it in all gears or just first i had a similar problem on my escort gti and it turned out to be the gear oil was low
  2. mk2 xr2 intermittent stalling problem

    hey m8 check the airfilter and any pipes vaccum leaks around the carb its probably something and nothing like a cracked pipe
  3. sub vibrating interior trim

    cover your boot all over with dynomat soundproofing stuff mine dosent rattle inside but its rediculous outside
  4. zetec conversion

    ive got an xr2i on a 1993 k plate n all u need to do is swap the head and throttlebody get a decent exhaust and whack a chip in it u should have around 150 bhp like mine pretty good fun till it rains then its like a boat
  5. loss off power

    first off check the lambda sensor and the air flow sensor common on most fords
  6. my fez 2i

    hey all i thaught id share a couple of pics of my 150bhp fez 2i
  7. start with the basics first m8 check the brake pads and the wires one of them could be damaged i had a similar problem on my escort gti and it turned out to be the pads i could be wrong but its easier to start with the easy stuff also when the light is on slam the brakes on to see if the abs kicks in then u may find it could be the clock panel im no pro mechanic but i do know a thing or three
  8. hey all

    hey everyone ive just stumbled across this site as i am a new owner of a 16v 150 bhp xr2i i swopped it for my escort gti and im well happy with it ill get some pics up at weekend