tankmurdoch

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About tankmurdoch

  • Rank
    Newbie

Contact Methods

  • First Name
    Gary

Profile Information

  • Gender*
    Male
  • Ford Model
    Mondeo 1.8 Edge Petrol
  • Ford Year
    2007
  • UK/Ireland Location
    Lanarkshire
  • Annual Mileage
    0 to 5000
  • Interests
    Classic Cars
    General Automotive
    Motorsport & Racing
    Computers & Electronics
    Literature
    Sports & Leisure
  1. Strange, my car is doing the exact same. Also vibrating at 60mph.
  2. You can get an aux cable here: http://www.amazon.co.uk/gp/aw/d/B001MKTYQ8/ref=redir_mdp_mobile?creative=22218&creativeASIN=B001MKTYQ8&linkCode=asn&ref_=asc_df_B001MKTYQ89977700&smid=A3LCOLEEP6SIHK&tag=googlecouk06-21 There is a port in the glovebox to plug it in, select aux on the stereo and you should be able to hear you ipod thru the speakers ok. I use it with my mp3 player however you still need to control the music with the mp3/ipod. Hope that helps.
  3. Coil pack fixed the problem, its like having a new car. Going to fill up and use some fuel injector cleaner. Thanks for your input guys.
  4. HT leads changed, no difference. Its in the garage now getting the coil pack changed, fingers crossed...
  5. Thanks guys, think i'll try the leads then the coil pack. Is injector cleaning fluid worth it?
  6. Hi, just recently my mondeo has started mis-firing. At around 1500 revs in pretty much any gear, especially the low gears. I've had the spark plugs replaced but hasn't made any difference. What could be causing it? What should I be asking a garage too, so I don't get ripped off? Is it worth trying injector cleaning fluid? Any help much appreciated.