Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


klouise77

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About klouise77

  • Rank
    Newbie

Contact Methods

  • First Name
    Kerry

Profile Information

  • Gender*
    Female
  • Ford Model
    Focus 1.8TD
  • Ford Year
    2006
  • UK/Ireland Location
    Shropshire
  • Annual Mileage
    20,001 to 25,000
  1. I think I have this issue is there a way of testing the oil or how to I check the injectors ?? Ford focus 2006 1.8 td and constant rising oil
  2. I bought a 1.8 diesel 2006 focus in July after a few weeks I checked the oil and noticed it was much higher than the level so drained some out then after another few weeks did an oil change , from when I had it the warning light kept coming on and took it to a dealer who said I needed a new turbo which was done and had failed due to soot. I got the car home and checked the oil level again and was again higher than the mark? Anyone got any ideas?? Thanks in advance
  3. Hello got a 1.8 diesel 2006 focus which has 57k on it bought it not long ago but got nothing to say the cambelt has been changed how often should it be done?? Thanks in advance Kerry
  4. Hello , im new to this so sorry if in wrong section Bought a focus 2006 1.8 td a few months ago and it does have some warranty on it but i have to pay and claim back , however the engine light keeps coming on so took it to ford and the problem is P0299 turbo under boost , they had it 2 days and couldn't find the fault and said it was ok , paid the diagnostic drove it that night and comes on again!! they said to try it for a few days and if happened poss look at new turbo. Trouble is there , touch wood so far, is no loss in power, smoke that would suggest the turbo could be on way out it drives fine??! anyone help?! thanks in advance Kez