Kev D

Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About Kev D

  • Rank

Profile Information

  • Ford Model
    S-Max 2.0 Zetec
  1. Hiya nedludd Hope you're sorted now - I eventually drove to the dealer that same afternoon and told them to find the fuse - the advice they had given me over the phone didn't work. Luckily, they had ordered my part ready for Friday and it had arrived within 2 hours so they fitted it on the spot - new wiper relay under warranty. Big up for Inchcape Bracknell! So I'm a happy bunny and I'm back onside with the neighbours.
  2. My May 07 S-Max decided to activate its own wipers this morning without rain, and I couldn't switch them off even when exiting and locking the car. The alarm then went off until I drove off again, the wipers gradually slowed from fast to normal, then intermittent before stopping altogether and now won't restart. That's not the problem - I located the wiper fuse, but the alarm keeps triggering intermittently and I cannot find the alarm fuse. The manual says it's in the rear fuse box, but the layout diagram looks nothing like the actual fuse box! My garage cannot take the car until Friday and I'll get an ASBO at this rate by then. Anybody got any ideas where I can find the correct fuse layout online or something???
  3. I have had a relatively trouble free year and a lot of fun with my S-Max, as have my two kids and three dogs. Just registering to share a problem or two and hopefully get some good advice. As they say...when in Rome...head for the Forum! :P