muggo

Budding Enthusiast
  • Content count

    25
  • Joined

  • Last visited

About muggo

  • Rank
    Member

Contact Methods

  • First Name
    Paul

Profile Information

  • Gender*
    Male
  • Ford Model
    Mondeo 130 TDCi Titanium X estate
  • Ford Year
    2007
  • UK/Ireland Location
    Leicestershire
  • Annual Mileage
    5001 to 10,000
  • Interests
    General Automotive
  1. It was a split intercooler hose in the end. I replaced it with a non genuine rubber one 10,000 miles ago & it cured it. However, I now have the same problem so i suspect it has split again. If so, I'll try a silicone version as it's a very low mileage for it to happen again.
  2. I was running low on diesel in my 2007 Mondeo 2l TDCi today. I filled it with 60 or so litres but the low fuel light is staying on. I've stopped & started a few times since, but the light remains on & the computer shows 0 miles until I run out, but I have a full tank. The fuel gauge shows full too. Can anyone suggest how I reset the light & computer please? Thanks Paul
  3. Thanks. That isn't the issue as the battery is fairly new & cranks my diesel engine in cold weather with no problem.
  4. Thanks for the good advice. However, the problem only happens about every 3 months, so it will take a long while to see if disconnecting all my electric windows has sorted it I really needed to see if this was a common fault with a recommended fix.
  5. Every so often, the windows on my 2006 2.0 TDCI Mondeo Estate come down in the night. Apart from it being a security risk, it could be raining overnight. I'm certain I'm not accidentally pressing the key & there are no water leaks into the carpet perhaps causing an ECU short. Does anyone have any ideas about what's causing it? Failing that, is it possible to disable the auto down windows feature as I never need it?
  6. UPDATE I've now used a tank of Shell VPower super diesel & plan to stick with it. It costs 5% more but gives me 5% more economy, lots more power & a much smoother drive. I only have to touch the accelerator & she just takes off! I imagine my emissions are much lower (no MOT worries) & it will only continue to get cleaner the more I use it. What's not to like? Many thanks to those who helped me in this thread. The least I can do is let you know the end result: an engine that feels like it has done 10k miles rather than the actual 141k. Cheers Paul
  7. UPDATE All seems relatively fine now. Performance is mostly back & economy is 48mpg on a long motorway run at 80mph. Still get some smoke when accelerating hard & I think it has lost a little low down torque as I stalled it yesterday & that's unusual for me. I'm still going to try VPower fuel & see what economy I got using a better fuel.
  8. OK. I see it might cost around £100 or so for a 2 litre diesel. I'll still try an Italian Tune Up & intend to use Shell VPower Premium Diesel every few tankfulls. The mileage I do means Premium Diesel would cost me about £75 extra a year if I used it all the time. If I use it 1 in 3 times it would cost as much as a Terraclean every 4 years. I can't see the car lasting that long...! Cheers Paul
  9. Thanks Sean Not sure it's worth spending £144 or so on a 140k mile Mondeo. I'm off for a 250 mile motorway trip tomorrow so the engine & exhaust will be nice & warm & hopefully burn off all the crap I've deposited in there recently. Regards Paul
  10. UPDATE After replacing the split EGR/Intercooler hose, it seems to have fixed the problem. Still plenty of smoke when accelerating hard but I imagine the exhaust must be full of unburnt fuel & a long journey should sort it. Surging & continual smoke has gone anyway. Power restored & having a clean EGR valve should improve fuel economy. I'll update when I know more. It was a bit tricky to remove the bottom hose jubilee clip without having a ramp, but using a 7mm socket on the clip sorted it. I removed the EGR valve to give me more room to work. Took about 75 mins in all. Thanks to all that helped with this.
  11. Thanks to all who offered advice but I think I've identified the problem: I'm now getting poor economy, lots of smoke, surging, low power & a whooshing noise when accelerating, all of which point to a leaking intercooler/EGR hose. I've spotted a split just down from the EGR & have ordered a new one from eBay for £14.45. I'll fit it on Saturday & hopefully have a trouble free trip to Devon on Sunday. I'm hoping I can undo the bottom jubilee clip via under the bonnet as I don't have a ramp or axle stands to remove the tray. If not I'll struggle from underneath. With my almost blocked EGR cleaned out & a non leaking hose, I'm hoping she'll fly! :D
  12. UPDATE I cleaned out the EGR which was very badly clogged up. However, it's still smoking & surging as before. I'm going to take it for a thrash shortly, but does anyone have any suggestions about what to try next? Many thanks.
  13. I did 290 miles at 60-80mph so it should have been clean & hot by then. Thanks for the reply though.
  14. Looking further into this I see that the EGR is likely to be partially blocked. I'll give it a go but I gather it should take about 45 mins to sort this. Is that about right? I can't afford to be without my car.
  15. My diesel Mondeo has just clocked up 140,000 trouble free miles. Yesterday though, on a 300 mile journey, I noticed a problem I'd describe as surging. On very light throttle, the power seems to come & go slightly. Sometimes it's bad enough for the rev counter to show a drop in revs too. I've had this problem before & have posted a thread asking for advice but nothing useful was suggested. The intercooler hose isn't split. Last week I had a "fuel service" including adding an additive to the fuel. I also had the fuel filter changed. Power seems slightly down but i could be wrong here. MPG is 48-50 on a long run so it can't be that bad. I've tried revving to max with a warm engine which kicked out some smoke but didn't solve the sensation I'm getting. Could this be a problem with an injector? At 140k miles, is this to be expected? Any advice gratefully received. UPDATE I've just been out & noticed lots of black smoke from the exhaust, most of the time (I must clean my back window!) Also noticeably down on power. Will more fuel additive or an expensive diesel tankful help? Can I thrash it better? Halfords who did the fuel service did a "before & after" emissions check but didn't give me the printouts as they usually do. Is this likely to be relevant?