Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


tractor

Budding Enthusiast
  • Content count

    51
  • Joined

  • Last visited

About tractor

  • Rank
    Settling In Well

Contact Methods

  • First Name
    Tractor

Profile Information

  • Gender*
    Male
  • Ford Model
    focus 1.6Tdci Titanium
  • Ford Year
    2010
  • Annual Mileage
    0 to 5000
  1. Yeah so chuffed Just hope this thread helps someone else before they shell out for a new instrument cluster Trac
  2. I've just had exactly this http://www.fordownersclub.com/forums/topic/72524-ford-focus-mk25-2010-titainium-d-instrument-cluster-fault/ Hope it helps Trac
  3. ****deleted**** Oops sorry wrong thread.......
  4. Update Cleaning the earths didn't make a difference. I had to take the car for mot today and of course it failed on intermittent tell tale lights. As luck would have it the tester has a focus with exactly the same issue he told me he wiggled a couple of fuses until the instrument cluster behaved its self. Well I've made four journeys since and everything's been fine. Fingers crossed that's it then....... Trac
  5. I'll second the above most likely the bonnet catch - its a common issue
  6. not sure if the key would cause the car to cut out? I've got a titanium with remote key and I once did a little experiment to cure my own curiosity, with the car running I took the key about 100 meters away from the car to see if the engine would cut out - it didn't. defiantly take it back to your dealer but my own personal guess which might not be useful but try changing the fuel filter, they're prone to getting blocked and could starve the engine of fuel, it happened to me once but the car went into limp mode rather than actually cut out. trac
  7. Ah Hec = instrument cluster they're the same thing thanks nexus no not put any LEDs in Second hand cluster is probably my best bet at the mo then trac
  8. I'll be cleaning all the earth points tonight then a great read here and pretty much sums up what I'm getting with the exception of the speedo behaving badly http://www.fordownersclub.com/forums/topic/48235-focus-instrument-cluster-erratic-behaviour/ trac
  9. hi guys I've decided to start a new topic as the old one is dated (I've not been able to touch the car for ages) and after investigation I think I've traced the issue to the instrument cluster here's the original thread http://www.fordownersclub.com/forums/topic/69986-2010-focus-16d-titanium-remote-key-unable-to-lock-car/ so it seems just remote key not working was just one of many symptoms. the other issues are dash board indicator lights not working, various warning lights randomly switching off and on, the immobiliser light flashing randomly, the temperature only displaying when it feels like it and the latest is the radio is switching its self off and on. in the original thread simcor suggest it could be a fault with the instrument cluster or HEC, someone please correct me if they're not the same thing, after reading through a number of posts on various forums I now believe this to be true as it appears to be a common fault. the most likely cause is some sort of breakdown in the soldering due to it now having to be Tin rather than lead based because of EU regulations. there's a lot of suggestions saying that just cleaning the solder points can make an improvement and even re-solder dry joints can fix it. so my question is has anyone tried this? if so did it work for you or equally has anyone sent their unit off to somewhere like http://www.clusterrepairsuk.co.uk/? or is there anyone on here who offers this as a service? I don't really want to have to go down the £500 ford dealership replacement road if I don't have to thanks guys Tractor
  10. just a thought? I know where the sounder is but if I cut the wire will that kill the ignition system? trac
  11. Little update I came out of work today and opened the drivers door, only to set the alarm off, and of course because the key fob doesn't work I couldn't stop it, I dunno if any of you have tried but it turns out even if you disconnect the battery the alarm still sounds, sorta good to know but it was a right pain in the !Removed! at that particular moment in time. It did eventually stop on its own. Probably not a good idea to discuss on a public forum how to disable an alarm but if anyone's got any suggestions I'd appreciate a pm So after messing around tonight I only managed to get round to disconnecting the battery for a full hour and reconnecting it, unfortunately the hasn't changed anything, Trac
  12. hey nexus sorry I didn't say earlier, I have wiped the codes a few times before I took the picture of the results but I haven't tried disconnecting the battery though, i'll do that first before I pull the HEC out ect thanks for your help trac
  13. perfect thanks for that Darren its much appreciated, I'll take a look and see what happens - fingers crossed trac
  14. brilliant thanks guys..!! so there's hope yet as the plot thickens............ I got in it this morning and everything was fine the instruments were reading as they should, the temperature reading was back and the warning lights had gone away. I drove to the nursery and dropped my little one off and the car even locked using the key fob great I thought but when I came back to the car it unlocked but when I got in everything was back to how it was yesterday...!!! so this does correlate with what your saying above, it could just be a loose connection or connection breaking down. the gem module should be easy to check but do you guys have any suggestions on how I pull the HEC/instrument cluster out to check it? cheers guys and gals trac
  15. Sorry HEC? What does that stand for? I think there's a test in for scan for the HEC I'll run a test Trac