Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Think Tank

New Member
  • Content count

    1
  • Joined

  • Last visited

About Think Tank

  • Rank
    Newbie

Profile Information

  • Ford Model
    Fiesta MK3
  1. Hello guys. I'm new to the forum, but I figure if anybody would know, you guys will. I bought a new car! Good times. The battery has gone. Bad times. It's an M-reg (96) Ford Fiesta. The battery terminals are *not* like this: http://www.rd.com/images/tfhimport/2003/20...ge003img001.jpg But I can't remember what they're called to find a picture. Instead, the battery terminals have a whole in which you put a bolt through, slip the cables over and then bolt it on with a 10mm bolt. It has four cables. One giant red (positive) one. The other three I'm not so sure about. Stupidly, when I took the original battery out, I forgot which one goes on which. I *thought* just the red one on the positive and the other three on the negative. However, when I do it like that, I get nothing. No lights on the dashboard. No clock. Nothing what so ever. Turning the key does nada. So, short of ordering a Haynes manual and waiting for it to arrive, I am wondering if anyone has any experience with this car so I can get the new battery in ASAP. I've checked the new battery at the shop which I bought it from and it is definitely working. But in my car... nothing. Any ideas please? Car is: Ford Fiesta 1.1 petrol with 5-doors on an M-reg plate. I think it is called a Mark '3.5'.