Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Hadleigh

Budding Enthusiast
  • Content count

    16
  • Joined

  • Last visited

About Hadleigh

  • Rank
    Member
  • Birthday 07/07/1989

Profile Information

  • Gender*
    Male
  • Ford Model
    Fiesta 1.25 Zetec 1999
  • UK/Ireland Location
    ---------WALES-----------
  1. Just the one arm i think the man said was bent or something? Not really sure if its the exact problem, the steering wheel shakes/wobbles at anyhtign over 50mph? Also would it be a MOT failure? Yeh power steering. It did have a buckled left alloy but changed that and the wobbling was reduced. Thanks
  2. When to get tracking done after i hit a bump/curb a bit hard and mechanic said i have a bent steering arm/rack How much will this cost fitted? Its for a 1999 T Reg Fiesta Zetec 1.25 Oh and are they easy to fit? and will this fail a MOT? Thanks
  3. Mines fixed!!! i took it to a garage and even though one of the fuses looked alright it was still faulty! try changing your fuses to a new set! Getting new speakers fittted in it in the next 2 days! Hope you get it sorted! Thanks everyone for your help.
  4. I think the door holes must be 10cm because these Vibe ones are 12cm and struggling to fit them in. You think i could cut 3 littles sqaures out the metal door in able to slide the speakers in?
  5. Just bought some Vibe SE-K 50 Door speakers with Tweeters (13cm speakers) Having trouble fitting them into the previous stock speakers space. Also the yellow and white wires - which goes in the red and which goes in the black on the new vibe speakers? Sorry im a n00b and dont know much! Ohh an no lights on the dask have come up, eveyrthign else works apart form the CD player not powering up, nor the stock Ford tape player. :\
  6. Wish i knew how to re-wire it all. Would take me days. Think i might go get speakers fitted now after work in halfords. Whats the map light? Before my headunit stopped working though my front left speaker was on its way out!
  7. Seems like your having the same problem as me. http://www.fordownersclub.com/forums/index...?showtopic=2767 theres the link of my problem and one member stated that it could be the speakers, but i havnt tried that yet just wondering if you could let me no if it is the speakers. All my leads are showing the correct volts and ohms aswel! Thankss
  8. usually just the speakers is it? Aw thanks man, im gna get them changed anyway because they are no way powerful enough they were like 10 watts or something. Thanks though!
  9. ive tried them in other cars and ive tried other headunits in my car so it means the fault lies with my car. You no in halfords when you get speakers fitted, do they rewire the speaker cable to or use the original wire? (becuase id preferably would want it re-wired aswel as new speakers) Thanks
  10. Actually thinking back to before it happened, my front left speaker was playing up and sounding as if it wa son its wya out! If i get new speakers fitted with new wires will this fix the problem as its sounds to be the problem!? Before i added the new headunit i didnt touch the speakers but i think i was playing them a tad too loud? I will check all these things in my car tommorow mid day!!! Thanks all. But is there anythign else possible that could be wrong/causing the problem?
  11. Just before i check all that tommorow morning, i just want to say that all this was working before something seemed to short with the wires coming out the back of the head unit? But before that everything worked fine, the ford original tape/radio player worked and all after market head unit's. The iluminating tape/radio player is the ford one that came with the car and doesnt need the halfords adaptor so all the leads are correct it just wont power on but iluminates the numbers and words around the LCD but nothing comes up on the LCD mini screen. SO it probably has nothing to do with the orange wire on the halfords lead :\ Although with after market headunit's nothing lights up at all! and nothing powers on. Do you think re-wiring it (using the halfords connector wires) to a after market headunit might fix it? Or are you saying something completely different? (Sorry im just not familiar with this kind of stuff and thats why i need some professional help from people like you ha) I will check the wires perm and ignition tommorow morning but im pretty sure theyre showing 12v. "do not run a cable direct to the 12v power of the car." - can you explain what this means? does it mean dont run one straight from the batteries 12v power of the car? Thanks very much i appreciate your help!!
  12. With a multimetre i check the original blue+black with a yellow and black power wire and they are showing 12volts - with the halfords leads that connect to the CD player i (when i connected that to the fiesta wires, the red and black power wires were also showing 12volts. Just checked the earth bolt on the chassis and thats showing up 12volts to. Any ideas what else could be wrong? I forgot to mention when i had the original ford fiesta radio in it wouldn power up but in the night when i had my lights on and the dask illuminated so did parts of the radio light up green like where the tape goes in and stuff but it just didnt power up. :\ When you say putting both the power leads of the radio on the perm, you mean with the halfords splitter rip the power leads out the block and connecting straight to the permanent 12v power from the car?
  13. no that still works, but if i pull the fuse out they obviously stop working (interior light) which means it isnt the fuse. Could it be the fuse in under the bonnet in the fuse box? can you tell me how to check the 12v of the permanent and ignition? and where can i find the Earth (and where would it be earthed to)? Thanks for the swift reply!!!
  14. 1999 Ford Fiesta Zetec Installed a Pioneer CD player by Halfords a while back replaced that with a Chinese DVD/CD flip out screen player and all was okay, blown the fuse in the car for the CD player previously but replaced that, but today after having the Ipod Plugged into the AUX on it, it died. Checked the black power cable for 12volts and it is showing 12volts, checked the fuse all okay! what else could be stopping the head units from powering up? Even tried the old Ford Fiesta tape player/radio headunit it has the green lighting around it but no power to the actual face of the unit! but as i said 12volts are going into it! What could have happened and how can i fix this? Thanks!
  15. looking to buy tommorow, can anyone give a proffesional answer ASAP please would be very grateful.