• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Brobert99

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About Brobert99

  • Rank
    Newbie

Contact Methods

  • First Name
    M

Profile Information

  • Gender*
    Male
  • Ford Model
    Fiesta
  • Ford Year
    2003
  • UK/Ireland Location
    Other/NonUK
  1. Clutch Pedal Problem

    Hi sorry to bump an old thread but do you have a link to the kit on eBay, I can't seem to find one A similar thing has happened to my 2012 focus - the plastic push rod has snapped and looking for a replacement rod without having to change the master cylinder Thanks
  2. Mk3 Focus Titanium - Zetec S Body Kit

    Thanks Lenny
  3. How Do I Remove The Sony Stereo From New Focus

    Sorry to bump an old thread but does anyone kno the answer tho this? Looking to fit my pioneer sub to this and wondered how it's removed and if there are any outpost on the back? Cheers
  4. Has anyone seen or fitted a Zetec S body kit to a MK3 2012 Titanium Focus? Been searching the net and cant even see them for sale anywhere. Any one seen them and any ideas of price. Can they be had from ford dealers? Thanks
  5. Is Econetic Any Good?

    Sorry to hijack the thread, but what is the real life mpg like on the Econetics?
  6. Deisel Smell Inside Car

    Have you checked the breather hose from the crankcase?