AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


jts

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About jts

  • Rank
    Newbie

Contact Methods

  • First Name Justin

Profile Information

  • Gender* Male
  • Ford Model S-Max 2.0tdci Zetec
  • Ford Year 2007
  • UK/Ireland Location Warwickshire
  • Annual Mileage 5001 to 10,000
  1. Power Loss

    Hi, I had a loss of power over the weekend with our 07 s-max 2.0 tdci, the engine malfunction light came on and it was as if the engine had literally lost half its power. It still drove, but pretty slowly. I managed to drive the 2 miles home, then the following day it was back to normal, no engine malfunction light and back to full power. Has anyone experienced anything like this before? Any advice would be appreciated, obviously I guess I should take it in, but if it is working fine now, will the garage be able to diagnose a fault?
  2. Power Loss

    Hi, I had a loss of power over the weekend with our 07 s-max 2.0 tdci, the engine malfunction light came on and it was as if the engine had literally lost half its power. It still drove, but pretty slowly. I managed to drive the 2 miles home, then the following day it was back to normal, no engine malfunction light and back to full power. Has anyone experienced anything like this before? Any advice would be appreciated, obviously I guess I should take it in, but if it is working fine now, will the garage be able to diagnose a fault?