• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


brianoz59

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About brianoz59

  • Rank
    Newbie

Contact Methods

  • First Name
    Brian

Profile Information

  • Gender*
    Male
  • Ford Model
    Mondeo tdi
  • Ford Year
    2005
  • UK/Ireland Location
    Dublin
  1. Mondeo 2Ltr Diesel 2005

    Thanks for that u guys, im having the coolant sensor fitted tomorrow, see if that sorts the problem, if not then will go ahead and do the other sensor and stat. Process of elimination, will keep u guys posted, Thanks again.
  2. Mondeo 2Ltr Diesel 2005

    Cheers for that Dan, feeling better now, i thought it might be something to do with temp sensor, Thanks again
  3. Hi guys looking for some help, every so often when driving, the temp gauge will drop down to cold, will still drive fine, but lose a little power and then pick up again, as soon as i switch it off and restart its fine again, sometimes it go to nearly cold but then climb back to normal temp, but eventually will go to show cold and fan will kick in. Any ideas or suggestions
  4. Rough Tick Over

    Hi guys i have a 05 Mondeo tdi 2ltr, i was getting the glow plug light flashing and would cut out, eventually glow plug light flashing and management light came on, fault showed up on computer as diesel knock cylinder 3, so had injector replaced, and glow plug and engine management lights are now not lit, but engine is running very rough and with what sounds like a diesel knock, rough tap tap tap, any suggestions would be helpfull