RobA

Budding Enthusiast
  • Content count

    16
  • Joined

  • Last visited

About RobA

  • Rank
    Member

Contact Methods

  • First Name
    Robert

Profile Information

  • Gender*
    Male
  • Ford Model
    Focus
  • Ford Year
    2007
  • UK/Ireland Location
    Kent
  1. ST rear diffuser for mk 7.5 zetec s?

    Love those ramps, where did you get them from?
  2. Don't what ever you do, get "event" tyres, the previous owner of my car had them put on by a Ford garage. They are absolutely shocking, every time you drove in the wet it was an "event", would constantly slide and spin even when just pootling about. Replaced then with some part worn contisport 5's, (6mm tread) for £80 for both, best thing I ever did!
  3. Ford Fiesta Suspension noise

    My 63plate titanium does it as well, only when cold, every morning when I leave for work I have to go over speed bumps and it does it every time, might get some of that spray and spray the bushes up and see what happens.
  4. New acquisition!

    Surely driving a left hand drive car in the UK is a bit of a pain? Have you got to get the headlights changed over so you're not blinding everyone, or does Ford do that as part of the import?
  5. HID H7 - D2S

    So I bought and fitted a 35W 5500k HID Kit from Amazon who I got the car in May and to be honest I wasn't too impressed with them, I found out about turning the bulbs over gets rid of the black lines so I did that and I have adjusted them to the best I can, but I'm still not happy, the actual light output is weak and doesn't show up the road to well. I've been digging around on the web and found some OSRAM Xenarc Night Breaker Unlimited, https://www.amazon.co.uk/XENARC-BREAKER-UNLIMITED-headlight-66240XNB-HCB-x/dp/B00FQ8AVHS Now these are D2S fitment which obviously doesn't fit in the H7 holder, but you can get adapter rings that allow them to be fitted in the H7 Holder, http://www.ebay.co.uk/itm/H7-D2S-D2R-Adapters-Philips-Osram-Xenon-HID-Bulb-/270354512667 If i get a set of these: http://www.hids4u.co.uk/d2-connector-cables-for-d2s-and-d2r-hid-bulbs.html And plug them into my current ballast will this work? Im going on the fact that these Osram bulbs will be a hell of a lot better than the cheap ones that the kit came with. Anyone tried this or have any other ideas? Ideally I would like to get hold of a regular D2S bulb that someone has replaced to see if it will actually fit with the adaptors before I forked out the money for the good bulbs, anyone have one kicking about I could have?
  6. 1.0 Ecoboost oil leak

    Do you not get 3 year warranty in the US?
  7. 1.0 Ecoboost oil leak

    Booked it in at ford and they turns out it was the cam position sensor, not sure what was wrong with it but they replaced it and all is fine. Spoke to the workshop manager and he said it's very rare to see one fail. Hopefully thats the last of any problems. The car does drive a better now, not sure if it's placebo effect or if it actually caused a problem.
  8. 1.0 Ecoboost oil leak

    Thanks guys, I popped into my local ford dealer today, I knew the workshop wouldn't be in but spoke to the sales guys about it and they'd never seen one with oil there. They said to phone the Peugeot dealer I got it from and tell them I'm getting ford to look at it as its still in warranty, and if it's something that isn't a warranty problem then I'd go back to them. So I'll get it booked in this week and see what happens....
  9. Hi, I bought a 63 plate 1.0 100hp fiesta last week, today whilst showing my dad the engine, we noticed some oil on what we think is the timing belt cover, its dirty, used oil, so not where its been spilt when filling up. I was serviced by the dealer before I purchased it so I thought it would have been brought up then?? The problem is that the Peugeot dealer I bought the car from is 2hr 30m away so I'd rather not have to take it back, as its a 63 plate it should still be in warranty, where do I stand with ford as I didn't technically buy it from them? Should I go straight to ford, or call up the dealer I bought it from and see what they say? Also, does anyone know where the oil could be leaking from? Apart from that the car is a blast, lovely to drive and even though its the 100hp its still pretty quick. Cheers, Rob
  10. Torque Setting For Callipers

    Thank you very much, very helpful!
  11. Changing my front pads this morning on a 2007 1.6 petrol and can't find my Haynes manual, can anyone tell me the correct torque setting for the wheel nuts and any calliper bolts please, cheers.
  12. I know this sounds silly but are you sure it was in the glove box and not in the boot with the tyre and all of the other wheel removal items?
  13. New 2015 Ford Focus Rs - Global Reveal

    As soon as I heard it was 4wd I thought, I'm sure someone on here was adamant it won't be.... Am I the only one that thought the reveal was a little cheesy, could have had Ken Block ragging the real one round rather than a prototype.
  14. Cheers guys, I've got a Haynes manual so will have a go at removing the starter and checking the ring. The coil pack I fitted is a genuine Ford item. I'll give Ford a ring for a price on spark plugs and HT leads on Monday, has anyone got a rough price to expect so I know if they're trying to charge me to much. The battery voltage is 14.2 volts when running so I'm pretty sure it's fine, I've got a charger to keep it topped up as it doesn't get used much now.
  15. Hi guys, Newbie here with a few problems with my 2007 1.6 115 petrol focus. Had some rough running last winter and had the EML come on, went to my local mechanic, plugged it in and it was the coil pack failing, so had that replaced and it seemed to be fine for a while. Then at the end of winter the coolant seemed to take a lot longer to heat up and whilst it was warming up the temperature gauge would go up and down until it got up to normal running temperature, as if it was letting cold water through and "cooling" the temperature sensor. The MPG was also very poor, (23, vs the 38 I'd had for the last two years). Went back to my garage and he recommend replacing the temp sensor as that sounded like the cause of the problem. I replaced that but by the time I'd done it, it was summer and I didn't have the coolant temp problem, now winter is upon us its risen its head again along with the poor mpg. I have also got a starting problem which to me sounds like the ring on the fly wheel has worn the teeth down which means the starter isn't engaging and just "tinging" on the worn teeth. If I push the car in gear and make the engine turn over manually it will then start fine. Or is it the battery starting to fail which isn't giving the starter enough juice to put the cog out far enough. I think it's the original battery as I've owned it since December 2011, haven't replaced it and it has got ford stickers all over it. Is my diagnosis correct, I believe its a gearbox out to replace the toothed ring? Last one, which I think is related to my first problem, when on the motorway using cruise control it will judder every so often as if it's got a slight misfire, reading on the web, if the ht leads are failing it can take to coil pack out as well so should I replace them? Sorry for so many questions for my first post, but I've finally decided I need to get it sorted and this seems to be the place to get some advice.