Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


Pidu

Budding Enthusiast
  • Content count

    268
  • Joined

  • Last visited

About Pidu

  • Rank
    Feet Under The Table

Contact Methods

  • First Name
    Peter

Profile Information

  • Gender*
    Male
  • Ford Model
    Focus Titanium 2.0 AT
  • Ford Year
    2006
  • UK/Ireland Location
    Devon
  • Annual Mileage
    5001 to 10,000

Previous Fields

  • Location
    Exeter
  1. Since I bought my focus I was thinking about fitting cruise control. Some may say it is not necessary, but I find it very useful on long motorway trips. Started searching for info on the internet and here are the results. Before buying any parts there is few things to check: 1. GEM number – according to info I have it must end with DX (where X could be any letter - A,B or any other), for example 4M5T-14A073-DW. I have read about another person who has successfully added Cruise Control to their Ford with a "C" GEM, but it was only one case and I am not 100% sure about it. You can read the GEM number on the sticker on the other side of fuse box. 2. Check the GEM connector 103 – blue one with two rows of wires, located on the left next to fuses – if it has brown wire attached to pin 10 and white wire attached to pin 18. 3. Check steering wheel clock spring connector if it has 6 wires – two are for the horn, two for the airbag and the two mentioned above are for the cruise control. To do this you have to remove steering column cover. The upper part has two hooks – you can see them when you turn steering wheel 90 degrees right and left. Release them and remove the cover. The lower part is fixed with two Torx 25 screws, but first you have to remove the radio steering controls. The Connector is under steering column just behind steering wheel. 4. Check if there are two switches present on the brake pedal as pictured below (black and blue). And also check if there is a switch present on clutch pedal (black, and of course only manual transmission). A Ford dealer mechanic informed me, that he has never seen a car without them fitted, but it is better to check your specific model before continuing. The next thing to do is to find a Ford dealer which will activate cruise control in our car and this might be the hard part. I did it while I was abroad on holidays so unfortunately I can’t recommend any dealer’s in the UK that would carry out this service. It might be worth asking some Ford specialist / independent garage as well. It is necessary to connect the car to IDS and activate / program cruise control in GEM module, the PCM module (engine control system) and instrument cluster (cruise control will work without it, but there will be no control light when CC is on). Parts required: If your car is currently equipped with a 4 spoke steering wheel then you just need to purchase a replacement 4 spoke wheel that has the cruise control buttons attached, it is not necessary to purchase a second airbag unit. Please note: The steering wheel with CC from the Ford c-max is not suitable for the focus. If your car has 3 spoke steering wheel like mine was, then the airbag will not fit 4 spoke one directly. But fortunately you don’t have to buy new airbag; you can simply get an airbag cover for the 4 spoke steering wheel. This is a genuine Ford part and the airbag will be fully functional with the replacement cover fitted. Do not bother asking your dealer for this cover because it is not listed as separate part. Instead go to e-bay for example see this link: http://www.ebay.de/itm/AIRBAG-LENKRAD-COVER-ABDECKUNG-DECKEL-FORD-FOCUS-/230613340397?pt=DE_Autoteile&hash=item35b1a050ed Before you start this modification and remove the airbag from the wheel it is recommended to disconnect battery. Remove steering column cover to get some space. Time to remove airbag – there are 3 holes in steering wheel from column side. Start from the side, turn wheel for easier access, slide flat short screwdriver all the way in (1), than twist it (2) and at the same time pull the airbag. Turn the steering wheel and repeat with two remaining hooks. When the airbag is unhooked disconnect the plug and connector as seen in the image below: Now easy part – unplug remaining connector, unscrew (key 27 as far as I remember) and change steering wheel. Then tight the screw, plug connector and it’s done. Fitting the airbag is very easy – plug in the connectors, put airbag in place and push it. If you need to change the airbag cover you will have to damage the old one, unfortunately there is no easy way to remove it and there is a risk of damaging the airbag. I found the easiest option was to cut it in pieces and remove in sections, avoiding any damage to the airbag unit. Once the old cover has been removed from the airbag unit, put new one in place over the airbag and push hard. I changed the cover after CC activation just in case it would fail and I wanted to fit back my 3 spoke steering wheel. To avoid airbag fault light on the connectors were plugged and the airbag was fittied with some tape in order to get to the dealer and back home. All together it took me around one hour to change steering wheel, most of the time I spent trying to figure out how to remove the airbag unit itself. All you have to do now is to contact your local Ford dealer and activate CC. In my case it took them about one hour to do this. Unfortunately I can’t exactly say how much money you will have to spend. I did this modification while I was on holiday abroad, the local dealer there had no problems with the LHD car, but not every Ford dealer wants to do this because “This is against Ford policy”. Parts bought over the internet and dealer labour costs were probably cheaper than in UK: - used steering wheel with CC in “like new” condition – 28.00 GBP - new airbag cover for 4 spoke steering wheel – 18.00 GBP - activation – 37.00 GBP Source of information and some of the photos: http://tentoys.livej....com/68940.html http://ffclub.ru/topic/3475/ http://forum.fordclu...ad.php?t=128806 Thank you for reading, I hope my guide is of help to others and should you have any questions please feel free to ask. Huge thanks to Lenny for help editing this guide. ------------------------------------------------------------------------------------------------------------------------------------------------------------------------ Courtesy of Richiemac: Also forgot to mention about a little GEM input test i found earlier..... Hold the heated rear window button in and turn ignition on. Keep button pressed for a few seconds and you'll hear a beep. Now when you use any off the stalk controls you'll hear a beep and the indicators will flash also. This beep/flash confirms the GEM input of the lights,wipers etc........... Turn ignition off to cancel. When in this test mode, i press the steering wheel buttons for cruise, i am getting the beep/flash... Reckon all i need is activation based on this test......... ------------------------------------------------------------------------------------------------------------------------------------------------------------------------ Courtesy of Stoney871: Did this test earlier and found that it did not cancel when ignition turned off. Had to follow same routine e.g. press and hold heater button on ignition to disable it. Thought i'd be stuck with it on whilst driving - not good... All fine now.. ------------------------------------------------------------------------------------------------------------------------------------------------------------------------ Courtesy of Murer87 You need IDS or go to a ford garage. Instructions: Firstly check calibration number in PCM programming and write it down. Then shut down IDS and this time let IDS connect to the car with IGnition OFF. After some time you will get to a point where it says that a new PCM might be installed. Leave Ign off and get to screen wheree it asks for PCMN calibration number. Enter the one you previously wrote dowm. Now go to programming, Module install and program PCM, it will then go through all the options fitted like cruise control (speed control) You need to reprogram PCM with the speed control active. Though you have to fool it by thinking you have installed a new PCM. Have ignition off whilst IDS is connecting. Then pick model manually and you will need PCM part number. You can get this on the programming page. Then it will go through various configuration questions about what is fitted to vehicle. ------------------------------------------------------------------------------------------------------------------------------------------------------------------------ Courtesy of Cragrat: Hello, After trial and error I finally found an EML327 that would run at a baud rate of 500000. Activated Cruise Control in the Gem and HEC. Doing the GEM test via the Heated rear window I get the beeps and indicators flash on all of the Cruise control buttons. So the Gem knows they are there. The switches are all present on the clutch and brake. So working through the set up in Wilcos post 1451 in Guide for Focus Mk2/2.5 C-Max/kuga~Elm 327 cable and Ff2 program etc. In the procedures page 2 screen I Read the firmware from PCM in file (saves as a bin file) reading complete in 3 minutes. Read the VID block from PCM blue bar shows progress and saved to my computer. Changed to configuration screen checked the Integrated Speed Control and saved as PCM config. Picture 2. Back to procedures screen page 2. Clicked on Load VID Block from file the only option in the box is to open PCM Config. Which I do. Picture 3. Click on Load Firmware from File box opens and again the only option is to open PCM dump 7M51-12A650AFD-Bin. Picture 4. This I did. I get the warning as in picture 5 There is a Non Empty VID Block etc I click on yes. Next Write current firmware in PCM. I get beep from Instrument cluster and Engine Malfunction warning. The Blue bar shows progress and it writes data to 97 blocks. Picture 6. It reboots when finished and up pops a box Reprogram Success in 3 minuets. I shut down program, turn off ignition. Unplug EML 327. Start car. Drive to local dual carriageway. At a speed in excess 60mph select cruise control via the button on steering wheel. Take foot off accelerator. No cruise control! I have now gone through this 3 times with the same result. Can anyone through some light on this or is my steering wheel going to end up on Ebay. My PCM number is in picture 1. Thank you Update from Cragrat: Could not resist a quick look at the car. I carried out the exact procedure as listed in my post 311 [Above]. Except this time when asked the question about the non empty VID block I selected ‘no’ as recommended by jarp in post 313 lines 3-5. and carried on until the reprogrammed box appeared. Took the car for a drive. Made sure I selected the buttons as in JohnH post 312. I now have cruise control. Very strange feeling as though I am not in control. But I will get used to it running up and down the M5. One other thing, I didn’t have the wires to the steering wheel from GEM. I checked that the pins were there in the GEM, and visited a scrap yard. Found a Focus with the wires, (unfortunately only a 3 spoke steering wheel) Cut the connectors off from each end. Took the pins out of these connectors and inserted them into the correct positions (10 & 18 in C103) in my connectors. Crimped wires in to join the two new connector pins together. Activated GEM and HEC cruise control and carried out the test using Heated rear window switch to confirm continuity. All working. My GEM is Pt No 7M5T-14A073-CF. HEC Rom 403 and PCM Pt No 7M51-12A650-AFD as listed in picture 1 of my post 311. The biggest problem I had was finding an ELM 327 that would run at 500000 baud rate. A big thank you to all who have contributed to this and hope my experience will help others. Any questions just ask. ------------------------------------------------------------------------------------------------------------------------------------------------------------------------ Courtesy of SkinnyB: Hi folks, been following this topic for around a year now. Bought a four spoke steering wheel and the airbag cover at least 8 months ago but from what people where saying did not want to rip my beloved three spoke out only for the CC not to work as my GEM was apparently the wrong type and being the tight ars£ i didnt want to pay someone to do it in case it didnt work either. But after the update to the PCM module in ELM Config i thought i would play around with it see what i could figure out. I did not want to lose my three spoke wheel, dislike the four spoke very very much think its looks too chunky IMO so i thought i would see if there was a way round it. I will just say now for all the perfectionists out there this was a try and error thing and is far from perfect but anyone thinking of doing the same can benefit from my mistakes :D 1st thing i done was to check that CC would actualy work so i took the CC connector bit from four spoke wheel and connected them DIRECTLY to the wires under steering wheel, on the way back home (had just done a night shift) about 40MPH pressed +set nothing thought ohh here we go :( then i pressed on followed by +set and ^_^ it worked CC light came on dash followed by the most unusual feeling after i took my foot off the gas and speed was maintained :o Half an hour later im home and started taking steering wheel apart :) i was just trying different things to fit the CC buttons Put the buttons into the steering wheel then cut the bits off on either side for the buttons (cut too much off on both sides so had to glue back some of the bits back) Screwed the buttons into place to the back of the steering wheel Put the airbag back on And this is the finished product Very pleased with the results and the buttons feel very secure too. Hope this helps someone, i have everyone on here to thank for all the information supplied. ------------------------------------------------------------------------------------------------------------------------------------------------------------------------ Courtesy of Carl0s: The picture thats on the pdf is pretty much the best i can come up whit, (i suck at drawing) but i try to walk you trough it. So, here you see that the resistors are all lined up, so that when no button is pressed, the current needs to go trough all of the resistors. When you push the OFF button, the current skips all of the resistors push the SET+ button, the current goes trough only the 120ohm resistor push the SET- the current goes trough the 120ohm and the 180ohm resistors push the RES button, and the current goes trough 120, 180 and the 300ohm resistors And finally, when you hit the ON button, the current goes trough 120,180,300 and 510ohm resistors. ------------------------------------------------------------------------------------------------------------------------------------------------------------------------
  2. Thank you all. Car and few parts (MK2 black headlights, MK2 and MK2.5 estate LED tail lights and 3 spoke leather steering wheel) are for sale, if anybody would be interested take a look at Buy & sell forum.
  3. Cheers FOCA, up to now I could only dream about such engine. Now we can afford it and I just could not resist
  4. Smile did not leave my face yesterday. Do not have many pictures so far, attached one of them. Really smooth ride, lots of power when you need it and 30mpg (as per computer) on the way home - both motorway and B roads, but I was taking it easy.
  5. Thank you Preee. Unfo I do not have much time recently and dis not post on forum, read from time to time. We will see. Yesterday I brought home BMW E60 545i, lovely car.
  6. So after 2.5 years of faultless drive it is time to say goodbye to my focus. It turned to be very reliable car. As new car arrived focus is for sale now. Thank you all for sharing your knowledge, your advices, mod ideas and great atmosphere on the forum. All the best and see you around.
  7. Arrow shows direction of fluid flow. It must point towards washer jet.
  8. Honestly I do not want to remove mat now, little bit to cold for me. You can find picture in this thread - post #8 http://www.fordownersclub.com/forums/topic/30877-mist-washer-jets/page__hl__%2Bmist+%2Bjets You will see piece of blue tube connecting valve and jet. I did it shorter, as short as possible and that is it.
  9. The whole problem is strange, focus is my first car with this issue. And unlike FOCA said it is not only water on the bonnet, those marks were hard to get rid off, normal washing was not enough. The way I see it Ford did not design washing system correctly, like many other things. Yes, there is a non return valve to keep the fluid inside tubes and prevent it from going back to the tank and actually this together with diameter of tubes and angle of the nozzles may be causing the problem. Tubes are about 5mm, while my previous cars were using 3mm tubes as far as I remember. When we use washers we are left with tubes full of washing fluid. While driving car is shaking and air slowly gets inside tubes from the nozzle side, obviously it pushes washing fluid out. Air must be getting pretty far, as nozzles dribble for a long time causing marks on the bonnet. I believe it happens due to "large" diameter of tubes. For the same reason Ford had to use non return valve as larger tubes require more time to fill, without valve it would take more time from pressing button to spraying from the jets and in some situations wiper would be moving on dry dirty windscreen causing scratches. When we fit non-return valve close to the nozzle there is only about 1 cm of tube filled with washing fluid. Even IF it will dribble it will be a very small amount of fluid. Other thing is I have used 3mm tube to connect non-return valve with nozzle, the only available in the store on that day. I remember I had to heat it up to fit. It is very short piece, valve and nozzle almost touch each other. The result for me is as written few posts earlier. Sorry for such a long post, shared few thoughts I had while having a beer :D
  10. Isofix screw holes are hidden dipper under the back of the seat, you can not see them on these pictures. Push hard the bottom edge of the seat next to seatbelt clip towards back of the car and you should see the plug. Take a look at this picture: http://files.myopera...mocowanie_b.jpg Sorry for the size, just found it on the internet as an example. You do not have to remove back of the sit to fit isofix.
  11. FOCA, sorry mate, but it looks like you did not read the whole thread and linked thread (post #4). Do it first please. It works, for me and many other Focus users from different countries. I found this solution on other forum and shared here. BTW Focus has one factory fitted non-return valve too.
  12. I can recommend these: http://www.ebay.co.uk/itm/WINDSCREEN-SCREEN-WASHER-JET-NON-RETURN-VALVE-5-MM-NEW-/271034453167?_trksid=p2047675.m1850&_trkparms=aid%3D222002%26algo%3DSIC.FIT%26ao%3D1%26asc%3D11%26meid%3D4984639945792718957%26pid%3D100011%26prg%3D1005%26rk%3D1%26sd%3D250863140738%26 I know they are not cheap, but genuine and high quality.
  13. I already forgot about those nasty marks on the bonnet since I fitted non-return valves last year. During that time I had 3 or 4 single marks (nothing like before) and they where gone when I washed the car, no problem at all, it did not require special attention / treatment like before.
  14. Search forum. Have already posted this "mod" with pictures some time ago.
  15. I found this trick on other forum and it worked for me. But I agree that ford mist jets are rather poor, it's hard to call it mist, I used to have much better ones in my Opel.