• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Nivek

New Member
  • Content count

    1
  • Joined

  • Last visited

About Nivek

  • Rank
    Newbie

Contact Methods

  • First Name
    Kevin

Profile Information

  • Gender*
    Male
  • Ford Model
    CMax
  • Ford Year
    2008
  • UK/Ireland Location
    Lincolnshire
  1. Hi, I have recently purchased a Ford CMax, it’s a 58 plate 1.8L petrol Titanium and has 14,500 on the clock, it’s now out of the trade dealers short warranty. The issue is at any random time, but seems more on a long run the power will just go, so I am in 5th gear doing 60/70 mph and then the car just starts to decelerate, like it’s going into some sort of safe mode, the engine is still running, but on pressing the accelerator nothing happens it just slows down, i have never let it continue to slow so not sure how slow it wants to run. I then drop the car into 4 gear and the power comes back, then into fifth again and all is fine. It might only do it once on a 30 mile run, or sometimes not at all. No engine warning lights come on, so not sure if it’s registering anything that a diagnostic run would pick up. It starts fine, no loss of power pulling away. Any ideas were to start, I have read diesels losing power, but can’t find anything on petrols.