• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Phil S

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About Phil S

  • Rank
    Newbie

Contact Methods

  • First Name
    Phil

Profile Information

  • Gender*
    Male
  • Ford Model
    Focus Mk2 1.6 Ti VCT Zetec Climate
  • Ford Year
    2006
  • UK/Ireland Location
    Greater London
  • Interests
    General Automotive
    Computers & Electronics
  1. Small Red Light Beside Zero On Speedometer

    I have had this light coming on intermittantly, coming on when moving but going out again. It turned out that the bonnet wasn't shut properly. Check all doors, boot and especially the bonnet are shut properly. Also check there is more than 50 miles worth of fuel.
  2. Oil Sump Plug

    My manual (which only goes up to 2009) says 21 lbf ft
  3. Hi all - new to the forum Read all these posts with great interest. I have had a little amount of water sometimes in the spark plug plastic well. I usually just dry it up with a bit of tissue. What I can't see though is how it could possibly get down to the spark plugs? There is a collar around every plug hole and that is fitted with the rubber lead bung. I see that in some of the above pictures you refer to a bung between plugs 2 and 3. I haven't got that bung on my engine. What is your model with this bung? - mine is the Ti VCT 115 engine. I never been able to properly tell whether the water is rainwater coming through the seal OR if it is washer water coming from the pipe connector. Suppose it's better to seal both. Are the Mk4 washers from ebay spoken about above a better fit and seal then? Might think about a pair of them. Thanks in advance for any reply.