Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


mk3pain

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About mk3pain

  • Rank
    Newbie

Contact Methods

  • First Name
    roy

Profile Information

  • Gender*
    Male
  • Ford Model
    mk3 escort
  • Ford Year
    1989
  • UK/Ireland Location
    London
  • Annual Mileage
    5001 to 10,000
  • Interests
    Classic Cars
    General Automotive
    Motorsport & Racing
    Car Restoration
    Car Modification
    Road Trips
  1. hi just stumbled accross this, i have an F reg escort wich had a 1.1 valenica engine ( pretty much a crossflow) and it had a 5 speed box, i decided to wip out the 1.1 and stick a 1.6 crossflow in wiccome from a mk1 fiesta with a 4 speed box however i decided to keep the 5 speed box and the transaction was pretty simple i kept the same flywheel clutch guide selector and to my suprise it fitted like a glove it was a pig getting it in the bay as the 5 speed was a bit longer however i just changed the mountings.. altho now u have me thinking as i have only recently had a rebuilt crossflow dropped in and trying to get it to start is a pig its tight as and there is a sort of grinding noise when i turn it over perhaps this is something to do with the gear box =/ altho all my gears work fine and slip into place and the flywheel ect is the same from my old engine so i cnt see y its beeing so stubborn ;( anyway hope my advice helped and good luck.
  2. Hi all basically id like to pick all ur brains concerning trying to get my crossflow to run! i had a new rebuild back in febuary and i dropped the engine into my car back then with help from a mechanic he wired up the dizzy and coil and done all the silly bits but we left the rad ect loose just to get the engine started.... however it had alot of trouble trying to start i undertsand it was new and it probably is tight but the compression coming from it is rediculous! i was sort of thinking the starter motor wouldnt have enough beans because it would turn over 2- 3 times then give up all together, since then i left it there due to moving ect.. i have recently started putting time and money back into it, i had a set of bike carbs jetted and a manifold made from bogg brothers, stuck electric fuel pump on and completed all wiring and silly bits i didnt finish bk in febuary e.g rad, fan, fuel pump.... i done all of this yesterday and yet i was still having the same problem, the engine just wasnt turning over quick enough even with a new battery and my mate in hes jeep jumping it also... we checked the plugs they all have spark, theres defo petrol getting to the cylinders as we took the plugs out and could smell it on the tips.. the dizzy as far as i know is right as it was put in by a mechanic even so ive been told it would start with the dizzy out by a few degrees but would just run like crap... i have now come to a brick wall as i dont know what else it could be any help or suggestions would be GREATLY appreciated, Regards a sad mk3 owner :(
  3. Hello all just a brief introduction my name is roy i have a mk3 escort 89 wich has a new rebuilt mk1 xr2 crossflow engine dropped in and i finally got the chance to hear it try to start yesterday but failed miserably and im not sure why, i have a new distributor + coil wich was fitted and is all in workin order as i have a spark its manual petrol pump wich wont feed the carb as the engine wont run so i tried to force feed the petrol through the carb and still had no joy so im not sure wether the carb is buggered as i brought it off ebay for £12 only solution i can come up with is to buy a new carb and see how that go's but that is turning out to be a problem in itself as i need a manual twin choke dft and i cant find 1 any where even burtons dont sell it, if a new carb fails to work does any1 have any ideas as to why it wont start? many thanks regards roy.