• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


roberts_ian1988

New Member
  • Content count

    1
  • Joined

  • Last visited

About roberts_ian1988

  • Rank
    Newbie

Contact Methods

  • First Name
    Ian

Profile Information

  • Gender*
    Male
  • Ford Model
    Fiesta
  • Ford Year
    2000
  • UK/Ireland Location
    Bedfordshire
  • Interests
    General Automotive
    Sports & Leisure
  1. Any advice or ideas are welcome, please help! I own a W reg MK4 Fiesta 1.4 zetec. I have NEVER hasd any engine, clutch, gearbox, battery problems or anything under the bonnet basically in the 4 years i have owned it. Has always driven smooth and perfectly. Yesterday i drove out of a parking space, stalled (embarrassing i know) and the engine would not start again. Was still turning over, battery fine etc. Towed it home, go a sort of mechanic mate who discovered that was just the fuse for the fuel pump, replaced, started fine and went to bed (it was late). The next morning had to jump start the car because the battery was drained from the numerous attempts to start the car the day before. Took the car for a drive and it now feels HORRIBLE! Every time i put my foot on the clutch it feels like its going to stall, the car feels like its shaking when this happens. When in neutral its shaking, the car just doesn't sound good at all, almost feels like exhaust is blowing but its in mint condition! I simply cannot figure it out! Any advice or questions feel free. Thanks, Ian.
  2. Welcome to the Ford forums roberts_ian1988 :)