• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


wollie

New Member
  • Content count

    1
  • Joined

  • Last visited

About wollie

  • Rank
    Newbie

Contact Methods

  • First Name
    kobus

Profile Information

  • Gender*
    Male
  • Ford Model
    sapphire
  • Ford Year
    1992
  • UK/Ireland Location
    Other/NonUK
  • Interests
    Classic Cars
    Car Restoration
    Car Modification
    General Automotive
  1. hey i have a ford sapphire ghia 1992 moddel. I live in south africa. It has the 3.0 v6 upgraded motor. The difrence as far as i know is the v is at a different angle what angle i dont know exactly would also like that question answered. It had fuel injection but gave problems so was converted back too carb thats why i know the v is at a different angle wasnt easy finding a manifold that fit. It also has hydraulic valve lifters. I would just like too know what the oil pressure should be on these motors. The reason im asking is i have a knocking sound but only from 2000 rpm up until 4000 but once leveled off the sound is gone. I changed the timing gears in front hoping it was them but it wasnt. I have already done 6000 km whith the car since i bought it so i cant see that it can be a main bearing as it would have ceased by now if it was. I've taken the oil preasure and is 350 kpa at idling when cold but when i rev it up to 2000 rpm it drops to 340 kpa and whith a warm engine it drops to 80 kpa at idling and 160 at 2000 rpm. So please any help. But i think its gona end up striping the motor. Hope someone can help me.
  2. Welcome to the Ford forums wollie :)