Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


SicStick

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About SicStick

  • Rank
    Newbie

Contact Methods

  • First Name Shane

Profile Information

  • Gender* Male
  • Ford Model Focus Zetec (climate)
  • Ford Year 2005
  • UK/Ireland Location Devon
  • Annual Mileage 0 to 5000
  1. 2005 Focus Handbrake Slipping

    Many thanks
  2. Morning all, As mentioned elsewhere I have procured a 2005 Focus Zetec recently, yesterday to be precise, and am just getting used to the features, but one thing has me concerned, the handbrake. On slops around 30 degree, I pull the handbrake up as far as it goes but the car will still roll. Upon reading the owners manual, it says that I should leave it in gear (1st or reverse) and turn the wheel to the kerb. It also says that the handbrake button should not be depressed when engaging the handbrake, I was always told that racking up the handbrake was not good and leaving it in gear on hills was not good either. So, is the rolling a sign off slack handbrake, should I take it back to have looked at? Or have I been using cars wrong all these years?
  3. No Rear Speakers 6000Cd

    Cheers for reply Preee
  4. No Rear Speakers 6000Cd

    Hi All, Just bought a 2005 Focus Zetec (climate pack), and discovered no rear speakers. (I just !Removed!-umed it would have some), anyway, my questions are - if I install some, will the head unit recognise them? will I be able to use the fade/balance button? does anyone know if any extra wiring would be necessary? as it is my understanding that the wiring for speakers/aux input is there, just not connected on some models Thanks in advance for any help
  5. Welcome to the Ford forums SicStick :)