AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Jameswill36

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About Jameswill36

  • Rank
    Newbie

Contact Methods

  • First Name James

Profile Information

  • Gender* Male
  • Ford Model Smax
  • Ford Year 2010
  • UK/Ireland Location Kent
  • Annual Mileage 0 to 5000
  1. 60,plate Smax Engine Problems

    Hi,I am quite new to this but,I have a 60 plate 2.0ltr diesel s,max,I have had it nearly 2 years now,I have had the car back to fords 3 times now,what happens is intermittent,one day the car would be fine then the next,I would start the car and it would run fine for about 10 minutes then I would notice that the main engine fan was on,there was a different exhaust note,and the engine was revving weird,it also has a loss of power,and a flat spot,I have had enough cars to no it's not right,I have like I said taken the car back to fords on 3 occasions,they run a diagnostic,and some other tests,but say there's nothing wrong,each time I go to collect the car they say they have updated the software,on the ecu,but as for the engine they don't know,I have to take it into them when it happens,that's helpful,has anyone got any advice,please,
  2. 60,reg Engine Problems

    Hi,I am new to this,I have a 2010 reg smax zetec diesel,has anyone had or no of a problem with the engines on this modal of smax,as I am having an intermittent problem with mine, it's been back to fords,4 times and all they say is it needed a software update,what happens is I can be driving it,and it loses power,the main engine fan comes on even if I have only been driving it for 10 minutes,the engine note changes,I can hear the exhaust poping,and it puffs White smoke out the back of it,but of course whenever it dose this fords have closed or it's a Sunday,and with it only doing it intermittently,they say they can't do anything,is anyone having the same problem,