Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


xristy007

Budding Enthusiast
  • Content count

    10
  • Joined

  • Last visited

About xristy007

  • Rank
    Member

Profile Information

  • Ford Model
    Escort XR3i Mk4
  1. No, but I will when the car is up and running! Thanks for the suggestion S-Max Bob :)
  2. Hi everyone, Sorry been away for a couple of weeks! So far, I've had the injectors cleaned professionally and they said apart from a poor spray flow, they couldnt find anything wrong with any of them. Well with high hopes anyway, I started to put them back in. 3 of them went in fine, but when I was putting the forth one in, the teardrop shaped piece of metal that pushes the injector in snapped as I was tightening the retaining bolt!!! So Im at a standstill until I can make another! Thanks for your suggestions weseeyou. I have replaced the plugs, and def have a spark, but when I get the car up and running, I will try the other things! Thanks again for your help.
  3. Just did a compression test and all 4 cylinders are giving out the same reading which is 12.5 BAR or about 180 psi. The oil looks a good colour ie not a hint of creaminess. The spark plug from the rogue cylinder was cleaner than the other three and was wet with petrol which suggests to me the fuel injector isnt blocked
  4. Not yet. I'll have to get a compression gauge and try it. If theres little or no compression is it serious money to get it fixed ? (whatever the problem may be)
  5. Just replaced the cap and repositioned the leads, and while it started better it didnt cure the problem sadly! The pipe on the exhaust manifold to the front and directly under the offending lead/plug/cylinder (the pipe on the end on the right) is cold when running, but the other 3 are red hot as you would expect. With new leads, plugs, cap, rotor arm and coil not making any difference, any ideas anyone? Cheers (a cheesed off) xristy007!!
  6. I took the cap off and replaced the rotor arm, but did not remove any leads from the cap. When I put the cap back on, the leads are tight and not as they were, suggesting to me that maybe the cap wasnt on properly? Its too dark now to do anymore, so Ill have a crack in the morning and report back! Thanks for the suggestion mate
  7. Hi all, My xr3i is only running on 3 cylinders. The one nearest the distributor cap doesnt appear to do anything! I removed the lead whilst the engine was running, and there was no change whatsoever, whereas removing the other 3 in turn caused the engine to cough and splutter until replaced. Ive changed the plugs and leads but still no joy. Has anyone got any suggestions? Cheers, xristy007
  8. Thanks mintalkin. Thats sorted and seems to run smoother!
  9. Hi all, Just bought a 1988 XR3i and while it looks lovely, it runs like a bag of you know what! Upon examination, I found the distributor diaphragm has a black rubber hose leading out of it, but the other end (of the hose) isnt connected to anything. Is this normal? Should it lead anywhere? On another issue, I started it one morning, and it seemed ok, but after getting petrol about 25 miles away, it wouldnt start (it wouldnt even turn over properly) I had put a new battery in the day before. It started ok with a bump start and ran fine (ie lumpy, but thats normal at the moment!) after that. Any suggestions? I live in the Woking area (Surrey UK) and if there is an XR3i mechanic/enthusiast/boffin that would be able to come over and check it out and tell me whats wrong with it, I will gladly pay them for their time! Thanks in advance for any help! Cheers, xristy007 (A non mechanic newbie!)
  10. Hi, Just bought myself a 1988 XR3i and thought I would say Hi! When Ive given it a clean, I'll post some pictures, but until then, Im in need of some help! Please see the the General Discussions/ Ford Escort Discussions section! Thanks Xristy007