AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About MrGrumpy

  • Rank
    Feet Under The Table
  • Birthday 07/10/1990

Contact Methods

  • First Name

Profile Information

  • Gender*
  • Ford Model
    MK II
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000

Previous Fields

  • Location
  1. Thanks :) I had a look at one th other day but it was a Ghia with the 2.0 engine so the goodies are no where near as good as the titanium x. I'm going back to see if I can have a little drive on friday
  2. Hi guys, I'm thinking of upgrading to a diesel for a number of reasons. So just want to know people's reviews or any known problems of the Mondeo Titanium/ x/ sport? I'm looking at the 1.8 or 2.0 tdci. Any info appreciated :) and thanks in advance
  3. I thought they used the same, same as the mk2 facelift ST/ZS
  4. Looks gorgeous, very well spec'd standard too! Good choice on removing both badges, looks a lot cleaner.
  5. I know what's needed for washers I'm just not too sure for levelling. They cost me £140 with postage mate, it's on just under 44k at the moment.
  6. Hopefully retro fit the washers, and not sure about the levellers, you got any ideas. I did take the car to an mot station to get the beam aligned correctly
  7. Been a while since I last updated, only a few changes. Carbon wrapped fog light brows Carbon wrapped headlight brows, which looked crap so they came straight off lol I've now got the full ST carbon effect dash trim, looking at getting the centre console soon Added team Heko wind deflectors And my most recent purchase is a pair of ST Xenon headlights Before After
  8. That's what I thought, but I'm sure I didn't have it ticked. Could be the case of myself downloading what I do have (from entering my vin) compared to what the software says I have installed and I'm trying to turn stuff on. Ill try a different way at the weekend and see how I go. Any idea why I can't turn anything on under GEM tab? Thanks Pree
  9. ok, not sure if this has been covered and its a lot of pages to search through to see if it has or not (lazy I know) But.. Ive managed to get everything working up until writing to the car.. but on the first tab (HEC) if i write what i want ticked when it finishes its magic, on my dash it has the yellow warning light and says TOTAL EPB failure and I can not write anything on the GEM tab as it says open Medium speed port. can someone help me on this please
  10. Just a note, my connector is fully wired up, so xenons should be plug 'n' play hopefully/surely
  11. Whats it like on startup? is there a squeel from the belts? when you turn the steering wheel is that when the noise starts? if so it may be the pump it self. luckily in my case it was only the union that had failed, but because the pipe connecting to the rack from the pump is press fitted in the union you have to replace the whole shebang.. :( Also the ppower steering pipe listed on Ford ECAT is the wrong one! be sure to check it before you buy it.
  12. relentlessanimal - PSN CoD series mainly
  13. Got my car back from the garage today, so I'll get a couple of pics of the layout on the back of the foam piece
  14. Its the Engine Management light, if you have a Code reader get it plugged in to see what it is
  15. Ok, so i downloaded everything and when it came to install i got this error message