• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


roscomagic01

New Member
  • Content count

    1
  • Joined

  • Last visited

About roscomagic01

  • Rank
    Newbie

Contact Methods

  • First Name
    Rus

Profile Information

  • Gender*
    Male
  • Ford Model
    C-MAX, Zetec
  • Ford Year
    2008
  • UK/Ireland Location
    Derbyshire

Recent Profile Visitors

1,133 profile views
  1. Dash Problem

    Hi, This is my first post so i'd like to thank everyone in advance for any feedback. We have recently had a problem on our c-max whilst we were driving. All of a sudden the temperature gauge went from reading the correct temperature to blank lines and the red snowflake came on to signal freezing or below even though it was about 10 degrees. The indicators do not make any clicking sounds when they are on and the full beam light doesn't come on when used. The indicators and the full beam work on the outside. We thought it could be the stalk which has broken as they are on the same one but the toggle works to scroll through the tripometer and the menu. The hand brake warning sign is permanently on along with the red snowflake. The warning noises for when the lights are left on when you open a door don't work. The door warning signs do not work. The central locking will open but will not lock the car. The boot has to be opened by the button on the key as the button on the car will not work. The internal lights remain on even when doors are closed and have to be switched off manually. The hazard light doesn't make any noise. The clock and the date reset at the time but now they are correct as we reset them. Our car mechanic thinks that we may need to take the car to a Ford garage to reset the computer as he thinks that there is a problem with the dashboard. Just wondered if anyone has had the same problem or if someone has any advice. Much appreciated. Thanks. 2008, 1.6, Zetec
  2. Welcome to the Ford forums roscomagic01 :)