• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Nidasol

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About Nidasol

  • Rank
    Newbie

Contact Methods

  • First Name
    Nick

Profile Information

  • Gender*
    Male
  • Ford Model
    Mondeo
  • Ford Year
    2010
  • UK/Ireland Location
    Sussex
  • Interests
    Classic Cars
    Travel
    General Automotive
  1. Hi Pragmatix, no oil evident, totally clean engne bay......
  2. Hi, New to the forum so please go easy on me. 2010 mondeo 2.0 ecoboost powershift, Great car to drive but when I bury the accelerator, and put the engine under pressure, the engine light comes on normally between 50-70 and there is a loss of power, and a definite stuttering in power delivery. This has also happened above 80 as well, but obviously not in the uk. Does anyone know about this, and the solution, other than not accelerating hard, as this means that I'll never be able to overtake.......... Ford dealership not able to give me an answer. Also the sat nav system has decided to not work on several occasions, no bluetooth, satnav, or usb but radio works, leave it overnight and all working again???? Thanks
  3. Hi, New to the forum so please go easy on me. 2010 mondeo 2.0 ecoboost powershift, Great car to drive but when I bury the accelerator, and put the engine under pressure, the engine light comes on normally between 50-70 and there is a loss of power, and a definite stuttering in power delivery. This has also happened above 80 as well, but obviously not in the uk. Does anyone know about this, and the solution, other than not accelerating hard, as this means that I'll never be able to overtake.......... Ford dealership not able to give me an answer. Also the sat nav system has decided to not work on several occasions, no bluetooth, satnav, or usb but radio works, leave it overnight and all working again???? Thanks
  4. Welcome to the Ford forums Nidasol :)