AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


fintious maximus

Budding Enthusiast
  • Content count

    110
  • Joined

  • Last visited

About fintious maximus

  • Rank
    Feet Under The Table

Contact Methods

  • First Name Andy

Profile Information

  • Gender* Male
  • Ford Model Modeo Estate 2.0 Zetec
  • Ford Year 2001
  • UK/Ireland Location Yorkshire
  • Annual Mileage 5001 to 10,000
  1. 2.0 Petrol Egr Valve

    Tried a swan neck but couldn't get it - maybe it needs a longer neck?
  2. 2.0 Petrol Egr Valve

    Decided to attempt a clean of the EGR valve yesterday to try and resolve the hesitation at 2000 revs so folowed the guide. Got the easy bolt out with no worries but couldn't get the rear bolt (towards back of car) off - how on earth do you get a socket or spanner in that tight gap? Any suggestions would be most welcome - I gave up and put it all back together and replaced about a litre of coolant but don't like to be beaten so will try again......
  3. Starting And Running Issues!!!

    Interested to see where this goes as my petrol Mondeo does the same at 2200 rpm. Have been trying to get round to cleaning egr valve!
  4. Front Wheel Hub Nut Loose

    Thanks for replies fellas, good news is that it passed MOT at 7 this morning with no advisories! I will mark it up to make a visual check defintely and is it worth putting some thread lock stuf on it? Will also get a new nut anyway. Thanks again.....
  5. Front Wheel Hub Nut Loose

    Thanks for the reply Dan but it is quite possible that the nut wasn't cranked up after the drive shaft was replaced as the car has done very few miles since then. Having read up in my Haynes manual it seems that the last part of the process is to torque up the bolt and the mechanic was rushing around answering phones etc during the job so may have overlooked this? I will keep a close eye on it and replace the hub if it re-occurs. Thanks again
  6. Front Wheel Hub Nut Loose

    Hi all, Took my car for its MOT test today and it failed on front wheel bearning having excessive play. (I take cars to local council garage who do not fix cars,only test them!). I thought it was a bit odd as I only had a new bearing and drive shaft fitted a few months ago. Anyway, got it home and in the garage and jacked it up to have a look. Turns out that the hub nut was loose so I have tightened it up and now the 'excessive play' has been cured. My question is - should the hub nut have a locking device as cars I have worked on before have always had a split pin to hold it tight. Incidentally,I only tightened it up with a spanner so will get a socket - think it's a 32mm if anyone can confirm?
  7. Leak - Looks Like Water/power Steering Fluid?

    Mine is watery/oily stuff though,thanks anyway
  8. Leak - Looks Like Water/power Steering Fluid?

    Thanks matey,any ideas where the leak would be coming from though and would it be an mot fail?
  9. Hi all, Can't get under the car to look properly as i'm on crutches at the moment. My 2.0 petrol has a smallish puddle under it (towards front of engine on drivers side) which seems to be a mix of water and redish fluid. I've had to top the power steering reservoir up but not coolant reservoir. Any ideas what this may be? It's in for MOT on Weds and would like to sort before if possible.
  10. Slight Hesitation At 2000 Rpm

    Mine is there regardless of temp, quite iritating!
  11. 1.8 Duratec Rough Idle Grr!

    Seems fairly common on this age of Mondeo (mine included) that they benefit from new plugs, leads and coil pack. Mine was a bit rough and hunting when I bought it and changed above and it was fine. Just started to hunt a bit at 2k rpm again but it did have an ebay special coil pack on so now looking at getting a better one. Hope this helps
  12. Slight Hesitation At 2000 Rpm

    Hi all, Just looking for some advice please. Car hesitates slightly at 2k rpm. I've changed plugs, leads and coil pack but it's still there - even tried another coil pack though admittedly not a Ford original. Is there anything else that could be causing this niggle? Also changed fuel filter!
  13. What Are Symptoms Of Failing Leads/coil Pack?

    Thanks for that Stef, looks like a V6one but will contact seller to confirm that it's just a stock photo. Don't understand about the unburned fuel bit? Is that what happens if the plugs/leads/coil aren't up to scratch?
  14. What Are Symptoms Of Failing Leads/coil Pack?

    thanks for the replies and no they weren't genuine parts. Think the coil pack was £18 from ebay (Ford wanted about 160). I'll bite the bullet and get some better kit and see what happens!
  15. Hi all, replaced plugs,leads and coil pack about 3 months ago as the car was juddering a bit. Bought bits on Ebay and last week the car has started to judder a bit when holding at around 2500rpm. I'm thinking rubbish leads or coil pack but wanted to see what you thought before I buy better ones. Someone suggested it may be the dreaded swirl flaps on their way - are they similar symptoms? Thanks in advance