Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About Fiestaalex

  • Rank

Contact Methods

  • First Name

Profile Information

  • Gender*
  • Ford Model
    mk2.5 Focus
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    10,001 to 15,000
  • Interests
    General Automotive
    Car Modification
    Road Trips
    Food & Drink
  1. Thanks for all the help, I might give that a go when i am feeling brave which will probably be next week now! I think the reason the speedo may have been fiddled with was that there was bit of damage sustained on that front corner of the car previously to me buying it which had been fixed :/ is the 'speedo test trick' where you hold down the mode button and put it into test mode and do the gauge sweep? I know that most cars underestimate the speed but my speedo does that as it should if you subtract the initial 5mph speed it shows at a stand still. For instance if i am driving at 65 mph on the speedometer it should say i'm doing 60mph and the sat nav will tell me i'm doing 56 so it shouldn't be that far out! I will try and get a picture of it at a standstill later to try and explain better! Many thanks again, Alex
  2. It was bought used and bought with the problem. Looking at that guide it seems that it might be possible to remove the needle and replace it starting at 0mph? is this correct? Not sure whether to attempt it myself or get the dealership to have a look! Thanks for the replies! Alex
  3. Thanks for the reply but my problem is that the speedo starts as if it was on 5mph instead of 0mph so if you are at a standstill it reads 5mph instead of 0mph. The speedo works as if it should but just keeps the extra 5mph onto the speed that it should say, it's almost as if the needle is just put on slightly off where it should be? Therefore when the speedo says 10mph your actually doing 5mph and say if you were doing 30mph the speedo would say 35mph. Hope this explains it a bit better! thanks, Alex
  4. Hi everyone, I have a slight issue with my speedometer. It works perfectly when driving but the only trouble is it starts on 5mph. So whenever i am driving the speed reads 5 miles an hour faster than is should show! Is it possible to recalibrate it or is the whole unit broken?? Many thanks, Alex
  5. Thanks for that it was really helpful! I will justy have to try and catch a good one on ebay now! :) Thanks! Alex
  6. I currently have the tape player/radio head unit in my car, what is the easiest/cheapest way to put in a cd head unit? Can i directly switch a 6000 rds head unit in if I bought one off Ebay? Many thanks Alex
  7. Hi everyone! I'm Alex and I am 18 from Cambridge. I am currently at uni. I have amk5 Fiesta flight but I would like a zetec s some time soon! Alex
  8. Welcome to the Ford forums Fiestaalex :)