AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About Timnchell

  • Rank

Profile Information

  • Ford Model
    Mondeo TDCi Ghia X
  1. Hi, I had the exact same problem with my estate version. Ford recognise the problem on the focus but not the mondeo yet. Bit the bullet and bought the new switch from the dealer for about £30. Perfect ever since. It all operates off a tiny microswitch under the rubber you push to open the boot. Hope this helps!
  2. Guess what 1500 miles on and its gone pear shaped again! Bit the bullet and took a chance on the cht sensor. My local dealer said it was not available as there is no stock! After 1 call to a dealer in Guildford they sent me one from London on a next day £35 in total. Not nice to fit. Cam Pulley has to be removed as it is behind it and you can only just get round one of the pipes. The sensor was bent and blue and all the wiring had gone hard from the heat . But on a plus side I did get to see the PAS belt was bad so got that changed as well . Happy Days!
  3. 400 miles later still going strong. Oil cooler thermostat in side of water pump took an hour to fit and cost me £14.00 from the dealer! MPG is also back to normal.
  4. Yes exactly the same, spin on oil filter, make sure you use good quality 5w30 oil. Happy Days!
  5. Now the management light on, replaced both thermostats and car is perfect Light has gone off fingers crossed!
  6. These seals are common for leaking. A quick call to the ford dealer and less than £10 cures. Obviously the wiring and leak off pipes need to be disconnected to put the new one in. Go carefully they can break off unexpectly sometimes. Its only a 10 minute job so a good garage will not charge you the earth for it!
  7. Car has done 115,000 miles faultless apart from a clutch. Car starts and drives perfectly but then all of a sudden the temp gauge will drop to zero and the car loses a lot of power. No engine management light comes on . When the car is switched off and back on it is perfect for another few hundred miles then the same will happen. H E L P!