Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


woody1511

Budding Enthusiast
  • Content count

    13
  • Joined

  • Last visited

About woody1511

  • Rank
    Member

Contact Methods

  • First Name scott

Profile Information

  • Gender* Male
  • Ford Model mondeo 2ltr tdci
  • Ford Year 2002
  • UK/Ireland Location Yorkshire
  • Annual Mileage 5001 to 10,000
  • Interests Motorsport & Racing
    Sports & Leisure
  1. Glow Plug Light 2Ltr Tdci 2002

    hi all, just fitted another fuel sensor on the second hand pump but still same ,but ive noticed if i let the car go into limp mode (by putting foot down over 70) if i stop immediatly and look at the injectors the middle 2 are swimming in deisel, they are dry as a bone normally if i dont go over 70,any ideas?
  2. Glow Plug Light 2Ltr Tdci 2002

    hi guys ,been real busy and had no time to repair car, had fuel pump fitted and still the same cutting out at about 70 ish,could be the second hand pump is faulty too
  3. Somebody Help Me Out Please - Hesitant Car

    i would go outside when its nice and dark ,remove engine cover and take a look at ht leads as engine is running ,you might see the ht leads breaking down and sparking on the engine,thats what my old escort did, i put new leads on and it ran great
  4. Glow Plug Light 2Ltr Tdci 2002

    thanks turbine ,will let you guys know how it goes
  5. Glow Plug Light 2Ltr Tdci 2002

    i need a new deisel fuel pump ,i can get my hands on a second hand 1, the guy selling it says it wont need programming ive read diffrent opinions on this, if it does require programing can it be done by anyone are is it ford only? thanks scott
  6. Spark Plug Gap

    haynes manual says 1.3 mm but ford say 1mm
  7. Glow Plug Light 2Ltr Tdci 2002

    hi mintalkin ,plumbob, ive fitted the grey cam sensor it did have the black one before but still same, the deisel specialist is going to have a drive in it at speed then hopefully tell me that it will only cost me pennys to sort it =) (says hopefully).ill let you guys know what he says,thanks for the replies ,scott ps ,plumbob do you know how much they charge to recondition the arm?
  8. Glow Plug Light 2Ltr Tdci 2002

    just had mine down to deisel specialist says its the turbo over boosting ,but fault on diagnostics says fuel pump ,i think im going to be spending lots =(
  9. Help! What Looks Like Some Heat Shield!

    hi ,if its not fallen off and is just loose try http://www.screwfix.com/p/no-nonsense-fire-retardant-silicone-310ml/77289 this will stick it back in place noprobs just clean any dirt from the surfaces 1st scott
  10. Glow Plug Light 2Ltr Tdci 2002

    hi, mine is the same as yours steve but i dont have the temperature problem just the limp mode when engine is warm at high speed ,i just didnt want to spend 500+ on a new pump to find out the problem is still there
  11. Under Car Moulding Broken

    hi maximus ,if its the trim that attaches to the rear bumper? i replaced my broken undertrim yesterday, when i removed the old 1 the rear bumper was very flimsey ,id say drill the rusted fastners out and replace with a wingnut type,are if you can buy the original fastners then do that ,i dont think the rear bumper would stay stable very long without the undertrim ,just my opinion scott
  12. hi all,great site, been reading up on the glow plug problems many of you have had, heres mine . i bought a 2ltr 2002 tdci the car runs great starts 1st time ticks over perfect no smoke ,untill i go on the motorway ,soon as i get to 70 miles an hour the glow plug light flashes and the turbo stops working and car goes in limp mode, i turn the ignition off and back on and car is perfect till i get back to 70ish again and the same thing happens again, i changed oil and filter, put a new cam sensor on and still had the same problem ,since then ive had the diagnostic check and it came back with only 1 fault ,which was fuel pump . i cant understand how the pump can be at fault if i can floor the car inlower gears without a single missfire but soon as its warm and high speed it goes into limp mode, i should also say when the car is cold i can get through all the gears foot to floor with no problems,its just when the engine as been running for 10 mins are so,and high speed that the problem occurs, any ideas ? thanks scott
  13. Welcome to the Ford forums woody1511 :)

    1. woody1511

      woody1511

      thanks steve=)