Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


a19rsy

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About a19rsy

  • Rank
    Newbie

Contact Methods

  • First Name Peter

Profile Information

  • Gender* Male
  • Ford Model Focus 1.8TDCi
  • Ford Year 2007
  • UK/Ireland Location Kent
  • Annual Mileage 5001 to 10,000
  • Interests Motorsport & Racing
    Car Modification
    Food & Drink
    Entertainment
    Computers & Electronics
    Sports & Leisure
  1. Engine System Fault

    It was serviced in the summer and the fuel filter was changed on that service. I have a tuning box on the car, could this be causing the warning message?
  2. Engine System Fault

    Hi, I have a Ford Focus Titanium 1.8TDCi on a 57 reg, and last summer a warning light on the dashboard came up saying: Engine System Fault. My brother-in-law managed to get rid of the message by turning the key in the ignition on and off several times, which he said used to happen on some Fords when he used to service them. This has now happened several times again, when looking in the book it says contact your Ford Dealer, has anybody had anything similar, as I don't want to take it the Ford Dealer and then have them charge me ridiculous money and say there is nothing wrong. When I have turned the key on and off several times and the message disappears there is no loss of performance. Help??
  3. Hi, I recently bought some rear LED tail lights for my Focus, but when I tried to fit them they wouldn't light up properly, they came on when I pushed the bulb into the holder, but when they were seated properly then won't come on. I have taken them out and re-fitted the original bulb, but this now doesn't come on either and I've bought some new 380 (P21/5W) bulbs to try and these don't work as well, can anyone help? Thanks Pete
  4. Hi, I have a 1.8TDCi Titanium (2007, 57 reg) with automatic headlights, and was wondering where the sensor is located, as when the lights come on after going through a tunnel etc, they stay on and do not go off. I have tried to turn the lights off and then back on to the auto switch, but they still stay on. The only way I can get them off is too turn the engine off, then on again and then they turn off. Can anyone help?? Thanks Pete
  5. Welcome to the Ford forums a19rsy :)