AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


civil-zz

Budding Enthusiast
  • Content count

    26
  • Joined

  • Last visited

1 Follower

About civil-zz

  • Rank
    Member

Contact Methods

  • First Name Sergey

Profile Information

  • Gender* Male
  • Ford Model FFII
  • Ford Year 2009
  • UK/Ireland Location Other/NonUK
  • Annual Mileage 0 to 5000

Recent Profile Visitors

2,845 profile views
  1. Hi sergey, im having trouble flashing the PCM for cruise control, ive done the HEC and GEM, can you have a look at my recent threads, im getting all the way to writing back to the PCM and when its finished its saying "There is a non empty VID block you need to reprogram the PCM" or words to that efect, can you help me please Sergey.

    im using a ch340t elm modified cable.

    PCM number  7M51-12A650-VE

  2. Milosh, it happens because ELM327 chip you have in your adapter doesn't fully correspond to original elm electronics specification. i don't remember the exact point but since one of the version the adapter soft reset command was added to avoid can-bus communication failures. some of the chinese firmwares process this command not correct and does the hard reset instead of soft reset including also a temporary set controller baudrate reset. decision is to write necessary baudrate to adapter constantly or just find another one which is equipped by a more suitable chip.
  3. emerald293, your issue isn't linked with PATS initialization or smth similar. just issue with elm327 adapter or computer performance. on these modules type (SID206, correct?) PATS init procedure MAY be required only when to update to some calibration levels. if process gets stuck on memory erasing stage then it means that adapter just can't get an answer on erasing command, there is no about PATS. best way is to change your ELM327 adapter. also changing connection speed or USB driver delay could help. one more point - if you was able to upload your original file then it means that modified file also can be uploaded. second point is whether it can be started after but it can be flashed into the module. seems that you equipment just works unstable.
  4. giorgiodav, battery voltage should be enough and central lock should be unlocked
  5. RB2004 understand your point, many thanks for the explanations! when i investigated this issue i found out that the st/rs and kuga have many differences in PCMs, such as for example security keys or memory addressing. at the same time st and rs are the same regarding these points. also st and rs can have the one module from the same set of bosch modules, here are their numbers: 0261209048026120909602612094680261209476026120948202612094830261209484 but no of them can be installed on kuga, it can have only next: 0261209354026120939702612094710261209472026120947302612094740261209533so i thought that this is the cause of situation why i can't read the kuga module and can't flash the custom calibration into it via obd. and was sure that st and rs are completely the same and there should not be any issues with rs. seems that i was mistaken.. troy45 you need to take the latest ELMConfig version (0.2.15), it has a tick on Page 1 of configuration marked as a steering menu availability.
  6. RB2004 what security are you talking about? did you try to flash stock RS module or after some firmware modification, for example from revo etc.? for my understanding the programming principles are the same on kuga, ST, RS. I flashed the kuga and ST but i have no RS modules in my own so the only attempt was to read the calibration from revo vehicle - without success, when I requested the memory address module answered with NRC 31 - request out of range.. what will happen if to take the stock RS and try to enter the programming mode, pass the seed request and give a command to erase and flash firmware?
  7. AT S1 command is need for newer version proper work. seems that your chinese clone doesn't support it..
  8. i don't know whether a value from test mode used for the pointer behaviour but yes, after TEMP/FULL version flashing the pointer value should correspond to test mode
  9. I've got it, many thanks. bad news - seems that VID decoded completely incorrectly.. and i have no idea what to do with it what is your real VIN, because i think that WF0GWF0GWF0GWF0GW is not a correct one? i'try to get data from as-built service if it possible. i think you don't mind if i answer your questions here? :) FULL and TEMP firmwares are the custom versions modified by our programmer with nickname quickie. TEMP version makes cluster to show the real engine temperature (as you know during warming up by default it shows 90 degrees when real temperature is only 45. and then shows 120 when it a already real danger to engine happens). so TEMP version arranges temperature and it's indication. as I know quickie made this modification for 1.4/1.6/1.8/2.0 engine maps so i'm not sure whether it will work with 2.5. FULL - its a TEMP version with adding a cut off the snow flake indication also. so you're right - its the only differences between them. your faults with cluster update maybe linked with low speed/big timeout (did you increase baudrate to 500000 bps/decrease usb timeout to 1 ms?) or low adapter quality - its the most often met cause. the most robust adapter i ever met is the ELS27 which is developed and produced here in Russia. it a bit more expensive then chinese ELM327 (at the current moment as i know its approx $30) but it is built from known components by a very experienced people with multiple functionality checks, it can work with baudrates up to 2Mb/s which allows for example to read SIM28/29 less then 1 minute, and also supports two buses from the box without any switches :) P.S. your car looks really cool and amasing, I love it :)
  10. No, it's better not to change anything. seems that RS VID-block coded differently then others. Could you please press "Save to file" button (leaving your VIN in place) and send saved file to civil-new@mail.ru ? Great thanks!
  11. I had done it with my car - all works perfectly, fold and unfold. unfortunately I think you can't get it anywhere else, only with DarkLeo's adapter and firmware. as I know it's a very hard work to rewrite a firmware - this work took a several months for him james_60, Pree, ADS uses it's own adapter, which has nothing to do with ELM327. It had the proprietary designed PCB and controller firmware.
  12. Could you please provide information about your dashboard hardware part number (HEC - Information - Hardware part number), better if it is a screenshot of ELMConfig window. Also I would be very grateful for the photo of your dashboard. Thank you very much in advance.
  13. Yes, it possible but not with ELMConfig. It's necessary to total reprogram door module. You can contact with DarkLeo on ffclub.ru, he is the author of a new firmware for DCU with auto-fold option.
  14. Teabags, I think, no. You calibrate zero condition - headlamp state which autocorrector will keep..
  15. Hi Preee, there was some small update (ELMConfig 0.1.1.8), it's availible through the previous link (http://civil.iffc.ru...g/ELMConfig.zip). Changes: - working with HCM module, including headlamp autocorrector calibration - fix bug which appeared if the echo was already switched off in ELM327 settings - the full bus loging during the work is now availible - DllPack has gone in past, now universal RuntimePack with installer is used (all Windows versions) (http://civil.iffc.ru...RuntimePack.exe)