Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About H8XME

  • Rank
    Settling In Well

Contact Methods

  • First Name

Profile Information

  • Gender*
  • Ford Model
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000

Recent Profile Visitors

1,781 profile views
  1. Wheres !Removed! pics gone?
  2. My 2013 titanium started to do this and my 2015 zetec s cheap glue. Sent from my D6603 using Tapatalk
  3. Around the same, bigger wheel-smaller tyre, smaller wheel-bigger tyre
  4. I'd try and compare with another side by side as they should be very quite inside, I often forget to turn mine off when refuelling, the face-lift version is slightly quieter then pre face-lift, with much less waste gate noise :( less Road noise :)
  5. Hi guys, any one had any issues with rust? As on my focus which isn't even a year old the rear suspension arms are falking paint and showing rust, I had this issue on my 2005 focus :( poor quality
  6. Is it just me or is there some thing very strange with there being no offerings for the focus while the fiesta has plenty? May be ford has told mountune to leave the updates to them?
  7. Space saver fell out of my old focus boot!!!!
  8. Hi Has any one upgraded their Bulbs and had good results, on my last focus I fitted a pair of osram night breakers which to be honest I could not tell the difference. Would any one recommend using 100w Bulds with a blue effect? Cheers
  9. Black or dark gun metal grey would set your car off. Sent from my D6603 using Tapatalk
  10. The only plus with drums is no brake dust :)
  11. Nice updates mate, for a final touch are you going to paint the alloys black? I wish mountune would pull their finger out and crack on with focus 1.0 mods :(
  12. The rear of focus breaks away easy any way so the best premium tyres are a must.
  13. I would nt worry it isn't that good
  14. My previous 1.0 focus had the same issue due to a pin hole in the cam cover. Ford tried 1st saying it was the silicone sealant. But re appeared so I took it back to dealers and they replaced with a new cover. Tell them it's a known issue Sent from my D6603 using Tapatalk