Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Lyts1985

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About Lyts1985

  • Rank
    Newbie

Contact Methods

  • First Name Lee

Profile Information

  • Gender* Male
  • Ford Model Mondeo
  • Ford Year 2004
  • UK/Ireland Location Torfaen
  • Annual Mileage 5001 to 10,000
  • Interests General Automotive
    Road Trips
    Food & Drink
    Entertainment
    Computers & Electronics
  1. Here we go... I'm basically looking for some suggestions or to confirm my fears as I can't figure this one out... It's a 2.0 TDCI 115, 04 plate, with 116k on the clock... My car is losing coolant regularly. 2 litres (roughly) every 100 or so miles... I can't see any external leaks, hoses etc, and a Ford mechanic agrees (take that how you will!) They did a pressure test on the cooling system which came back fine but said a sniff test would be pointless on a diesel (?). The mechanics advice was that he suspects a head gasket failure as he noticed substantial white smoke when starting from cold... He's right - when the cars been sat overnight there's a shed load of white smoke, then when I check the coolant level it has indeed dropped. The smoke clears after say 15 seconds of rough running but then runs perfect and doesn't lose any more coolant during running... My limited knowledge tells me that water is running in to the engine overnight hence the rough running and smoke, but if the head gasket were gone would it really leak in to the cylinders overnight and not during use?? What else could cause this as I could do without a £1000+ bill right now...? Unsure if it's related so I'll ask the question... There seems to have been, at some point, a leak around the EGR valve as there's something running down the bottom hose? Thought it was only exhaust gas going through the EGR? Finally (honest!) there appears to be fluid (water??) around the injectors and the surrounding area... Normal? I'd greatly appreciate some technical bods opinions on this... Thanks!!
  2. Mondeo Tdci 115 Poor Mpg - Stumped!

    Brill, cheers for the tips :-) I get just short of 400 miles a tank which works out roughly 30mpg
  3. Mondeo Tdci 115 Poor Mpg - Stumped!

    Hmmm interesting - mate of mine has the same engine in a Zetec roughly the same age/mileage and averages 39mpg, mostly town driving. I probably do 75/25 town/motorway. I get just shy of 400 miles to a tank where he's getting close to 500. Maybe I'm just being picky but my old Vectra DTI (51 plate, 100k) would get close on 38mpg so expected better from the TDCI... Out of curiosity what mpg do other people get out of this engine? Or miles to a tank? Cheers for the replies :-)
  4. Hi guys Ive recently bought an 04 plate Mondeo 2.0 TDCI 115 with 113k on the clock, that's averaging 30mpg. That seems ridiculously low to me so... I've had the injectors professionally replaced I've replaced the EGR valve and cleaned the inlet manifold, replaced the fuel filter, and air filter The air filter to turbo hose was split - I've replaced it The EGR to inter cooler hose was split - I've replaced that too But it's all made very little difference and now I'm stuck for ideas. Can anyone suggest anything I may have missed?? I'm beginning to think it may be something electrical but is there anything mechanical I should check? Cheers
  5. Welcome to the Ford forums Lyts1985 :)