Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


roynomad

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About roynomad

  • Rank
    Newbie

Contact Methods

  • First Name
    roy

Profile Information

  • Gender*
    Male
  • Ford Model
    focus 1.8 tdci
  • Ford Year
    2003
  • UK/Ireland Location
    Leicestershire
  • Annual Mileage
    10,001 to 15,000
  1. Hi, own a 2003 1.8 TDCI focus.. 130k on the clock, full service history.... Problem only started the other day, doing a slow U turn and it just lost all power and cut out. Started fine, did another U turn and it cut out again. Theres no smoke and it was running really well, Ive done 150 miles on the same fuel and still have over half a tank. Went to work in it that night and drive home in the morning with no problems. Loaded the car for a weekend away, it stalled twice on the drive but i put that down to me. Drive 3 miles down the road and it lost all power and the engine cut out. Managed to get it home by stop start driving. The last half mile it seemed fine so i nipped up the road and a couple of miles it stopped again. Im sure it aint the fuel but could it be the cam shaft position censor or the fuel filter housing ?? Any help would be good as i know nothing about cars and im pretty skint..... Thanks....Roy
  2. Hi, my 2003 1.8 TDCI has just started to do the same, and i think if i drive at low revs it seems ok..
  3. Hi, only had the car a couple of weeks and im happy with it. Yesterday under normal driving it just cut out. I pulled over, started, drove a hundred yard and stopped again. Its just loosing power. On restarting the rev counter sometimes vibrates around the 2/3 k... Its been on the same derv for the last 150 miles so still has the 3/4 of a tank of the same fuel. It has a recut key so no buttons just normal key in the lock central locking.. Other than this it runs really good.. Can anyone help with ideas....Roy
  4. Welcome to the Ford forums roynomad :)