AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


rivnog

Budding Enthusiast
  • Content count

    13
  • Joined

  • Last visited

About rivnog

  • Rank
    Member

Contact Methods

  • First Name
    nathan

Profile Information

  • Gender*
    Male
  • Ford Model
    focus tdci 115 estate
  • Ford Year
    2002
  • UK/Ireland Location
    Essex
  • Annual Mileage
    10,001 to 15,000
  • Interests
    Classic Cars
    General Automotive
  1. surely then much accept some responsibility. But how you get them to pay or do the work is another matter... I had escort tdci 1998 the cam belt shredded the teeth, breaking the cam shaft etc So I had a local firm put a new head on the engine and I was back up and running Then one day I decided to change the plugs only to find 1 was broken off in the head.....great and thanks guys!!!! I got some metal fabricators that were working onsite one day to weld a nut on the end of the snapped glow plug but that just twisted off.. In the end the car ran well for another 10,000 miles and then I got shot of it I not sure if driving on 3 plugs is bad for your engine, I'm sure someone will let us know... I'm also sure someone said that the compression is enough the ignite the diesel fuel but I don't know if that correct. all the best and good luck
  2. Different engine bay to mine. I think you will find your glow plugs under the oil filler plastic. I can see the injectors so your plugs are near by, there is one per cylinder 4 linked together with 1 red wire which bolts down to each glow plug.
  3. Good point Are you actually from Maldon? I was born in Maldon now in Tollesbury
  4. So after about 2 months of a squeaking noise coming out the engine bay of my focus tdci I think the fuel pump that runs off the auxiliary drive belt has pack up. Over Christmas I changed the drive belt to rectify the squeak but the squeak was still present after. The car on the way home yesterday the car just lost loads of power, really rough and now will not start So the car is in fair condition good engine 142000 miles. Thinking now that I should scrap it, break it, repair it or Ebay it. Any comments welcome
  5. I now put this problem down to a knackered battery. I think on starting up the battery wasn't turning the engine over quick enough and the glow plugs could not function correctly. Since fitting a new 76 amp battery both the shaky start and cold start issues have now been sorted
  6. So I did my glow plugs back in December 2012 hoping that it would short out my cold starting problem but it didn't. So now in December 2013 my battery started to fail. After much hunting and research I changed the old 72amp battery to a 76amp model which has now completely fix the problem. I got the battery from Ebay for I think £46 delivered
  7. funny thing happened on saturday i start my car up (Focus tdci 2002, 131000 miles) and when it started it was was sounding really wierd and all shaky and out of sync. So i quickly turned car off, re staredt it and it seemed fine but the clutch pedal only came up half way. Generally the clutch is fine and doesn't slip Anyone got any suggestion whats was going on
  8. just changed my glow plugs. A lot easier than i thought Job done within an hour, remove the intercooler and dripstick holder and away you go. total cost £41
  9. leak stopper worked for about 3 months but it's started losting water again..... I've now got a thermostat housing from a local breakers cost £10 so i'm going to have a go over christmas. I assume there is a gasket that goes between the engine and the housing?
  10. I too had this problem with my car, focus tdci 115. It would just cut out at 70mph. It turned out to be my injectors. It cost a lot of money but it fixed the problem A nearby diesel delphi speclised fixed my car but since then i have found cheaper delphi garage. They could check for any faults on their computer,
  11. i think your right it is the thermostat housing. Going the try some Bars Leak stopper first. Then maybe a local garage
  12. I've got a focus tdci 52 plate with a slight leak of coolant coming from a plastic hose fitting bolted to the engine block with 3 bolts in a triangle shape. The plastic fitting is located by the dip stick it has a single large diameter hose coming out of it in a downwards direction at 45 degrees. Sorry for my poor discription but, My question is does anyone know what the fitting is.
  13. Welcome to the Ford forums rivnog :)

    1. rivnog

      rivnog

      cheers steve