Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


ozworthford

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About ozworthford

  • Rank
    Newbie

Contact Methods

  • First Name
    andrew

Profile Information

  • Gender*
    Male
  • Ford Model
    galaxy
  • Ford Year
    2004
  • UK/Ireland Location
    Yorkshire
  • Annual Mileage
    10,001 to 15,000
  1. Hi, Iv'e got a Galaxy 1.9 TDI 130bhp. Engine type ASZ. The loom in the engine bay has melted. I have been told that a new loom is very expensive. I can't find a ASZ loom but have found a loom on ebay and it is for a 115 bhp engine. This is a AUY type engine. Daft question but i'm going to ask anyway....can you use a AUY loom on a ASZ engine?
  2. Hi Greg, the fuse is under the steering wheel on the drivers side. Problem a bit more extensive ...see post "melted loom" for the more details Oz
  3. Got Galaxy diesel tdi 2004. Had fuse 3 blow a few months ago. This knocked out the speedo, indicators, trip computer, semi auto heating. ABS warning light came on and brake warning light came on. Trip Computer telling me to refuel. New fuse - all ok and more importantly the car could still driven...bear this in mind. This time I smelt burning and fuse 3 had melted. Same things knocked out but I could still drive the car. Took it to the local garage. Electrician had looked at it. For clarity I haven't yet spoken with the electrician but the garage says that the air con sensor behind the drivers headlight had shorted and the loom in the area under the air filter box had melted. The fuse holder in the fuse box for fuse 3 had melted. I have seen this. The garage says it could take a week and £1500 + to fix because the all loom needs replacing. They think that also the ECU could be damaged . Considering that I have drove the car would this be the case?. I had a ECU go on another car and I couldn't drive it. If I replaced the fuse box and only the melted loom would this be enough to rectifiy the problem? Does the whole loom need replacing? Any ideas?
  4. Hi, Check fuse 3 (5 amp) in the the fuse box on the drivers side. This has happened to me twice now the latest being this Friday. I'm afraid I can tell you what has caused it but the first time it was a simple fuse change. This time not so lucky...melted fuse and part melted fuse box. The car is in dock at the minute and will be going back to the garage tomorrow to sort out...hopefully!!. What I can tell you is that it is absolutely nothing to do with the pollen filter. I'll keep you posted.
  5. Welcome to the Ford forums ozworthford :)