katelyndon

Budding Enthusiast
  • Content count

    76
  • Joined

  • Last visited

About katelyndon

  • Rank
    Settling In Well

Contact Methods

  • First Name
    kate

Profile Information

  • Gender*
    Female
  • Ford Model
    mondeo
  • Ford Year
    2003
  • UK/Ireland Location
    Worcestershire
  • Annual Mileage
    0 to 5000

Recent Profile Visitors

1,269 profile views
  1. took it to transit centre and they said it was the abs rings on the front shafts we damaged while doing ball joints. all good now but don't know what they were
  2. thanks. I will check the sensor again. Thank you tdci-peter
  3. hi all. changed the ball joints and track rod ends and links on my 2007 RWD ford transit. now the abs light with esp wont go off. had computer test and was told it was something to do with steering and something about longitude. took it to chemix for alinement with print out but lights stay on. any ideas before I take it back to transit centre to sort out. this van is costing me loads. any ideas please
  4. thanks. just bled the front
  5. hi, here again for a bit of help. just changed ball joint on my 2007 transit RWD. while doing it I broke the end off the brake pipe so had to renew it. will I need to bleed all the brakes or just this front one or both front ones. thank you
  6. thanks for replying. Forgot to say its a 2007 transit 2.4 140bhp. So dearer engine. I wanted to skim head and new gasket but if it's the block when they change it, it will cost more in the long run. But as I said it didn't loose no power and for some reason didn't overheat. But lots of pressure in water system
  7. took my transit to transit centre and was told I need a new engine. It was blowing white smoke and loads of pressure in water system. They said water was in the pistons and in the oil. Ok. But it didn't overheat and didn't loose power. The is no oil in the water system that I can see.. Any chance it could just be cylinder head and gasket or do I need a new engine. Any ideas. Thanks
  8. hi, me again. took my transit up transit centre because of loads of white smoke. water in the oil, but they drove it back to me and told me I need a new engine. before they drove it back they had to unlock or unblock it cus pistons were full of water. I asked it if could just be cylinder head, he said no, need another engine. anyone know why he said another engine and not cylinder head or gasket. it still drove good, no power loss . transit 2007, 2.4, 40bhp. any ideas
  9. engine knackered
  10. thanks for replying again. I have got it booked in tomorrow and was told the same as you say about the fuel rail or a injector. I just hope its not cylinder head. but its smoking just like last time when turbo had gone, but this time with hard starting. I will let you know what they say but it will probably be a week for them to look at it. thanks again pete
  11. it was a cheap speed sensor I bought off ebay. thought the first may have been faulty so ordered a 2nd. no luck. so ordered one from ford and took the abs light off straight away. luckily I sent the 2 back and had a refund
  12. hi all. I have a 2007 transit van, 2.4 140bhp. lately it has become hard to start. it is blowing white smoke out the exhaust. temperature is normal, heater blows hot air and doesn't loose any power. I have tested water for contamination and oil is normal, no creamy sludge or anything. I was told it could be something to do with diesel not getting through to start, but why the smoky exhaust. I have recently had a new turbo fitted and all was good til now. any ideas anyone, thanks
  13. thank you both for replying. Tdci-peter, I did go to site, it may have helped a bit. Thanks
  14. just bought a second hand abs pump and module as had it tested at ford and said I needed a module. Do I have to have it re set or what do I do when I put it on. Thinking of just changing the module . Its on a 2007 transit
  15. just bought a second hand abs pump and module. How do I re code it or what do I do when I put it on. Thanks