• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


StevoBow

New Member
  • Content count

    1
  • Joined

  • Last visited

About StevoBow

  • Rank
    Newbie

Contact Methods

  • First Name
    Steven

Profile Information

  • Gender*
    Male
  • Ford Model
    Lots
  • Ford Year
    2012
  • UK/Ireland Location
    Suffolk
  1. Hi Guys... just a quick little 'How to' for that annoying noise you get with the titanium fiesta... Firstly you have to remove the plastic around the gear lever... Just have to pull it up to do so. Next... Remove the little bit of plastic under the radio... small flat blade screwdriver in the center and it should pop open and all you have to do is gently pull it off. Next... Remove the trim around the climate unit which is held in by a few metal clips.. Gently pull it and it should all pull away. I started at the bottom and worked my way slowly to the top. Next... Unscrew the 4 torx holding in the Climate unit and the 2 holding the clip above and disconnect the unit. Very easy,, 2 clips that you press the top down and slide the black part across (not in the pic but makes sense when its in front of you) In the hole you'll find this... the cause of the problem!! It's vibrating against the trim. The trim is somehow acting like a speaker and making the noise far worse then it is!! Cable tie it to the wires for the climate control and it should fix the problem!! Now all you gotta do is put it all back together in reverse!! Good Luck :D
  2. Welcome to the Ford forums StevoBow :)