• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


roscoeuk

New Member
  • Content count

    1
  • Joined

  • Last visited

About roscoeuk

  • Rank
    Newbie

Contact Methods

  • First Name
    Roscoe

Profile Information

  • Gender*
    Male
  • Ford Model
    Fiesta Flame 1.4 2003 5dr Manual Petrol
  • Ford Year
    2003
  • UK/Ireland Location
    London
  1. Hi there, I have just bought a 2003 Fiesta Flame, 5dr, Petrol, manual from (what appears to be) a reputable dealer in Surrey. It was a part exchange for the previous owner. The car has done 50,000 miles and had a good service history (2 previous lady owners). I have a service report from every year since 2005, with the latest being August 2011. Mosty of the services are simple oil/fluid checks and replacing filters. The clutch was replaced in 2010 and I think the water pump was replaced at some point. Overall, the car seems to run well and appears to have been maintained well. Ok, I'll get to the point. I have noticed a slight hissing noise coming from the right hand side of the engine (just to the right of the air flow system). It doesn't appear to affect the performance of the car. I only notice it whilst idle as well. Apart from that the engine seems healthy sounding (to my untrained ears). Also (and this may be unrelated), it feels like I can hear the throttle and engine coming through the dashboard. It also seems to hum whilst sat in the car but can't really hear when I'm actually looking at the engine with the bonnet open. I would be grateful if anyone could share a similar experience or suggest any ideas of what this could be (if anything at all, it may be normal). The car has a 3 month used warranty so have the option of taking it back in, they offer servicing there as well. Many thanks, Roscoe
  2. Welcome to the Ford forums roscoeuk :)