AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


iano

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About iano

  • Rank
    Newbie

Profile Information

  • Ford Model Fiesta
  1. Could be it also. But given the serious lack of coolant + the frequent web references to "Rid yourself of airlock associated with low coolant levels, so as to get the heating working again", I'm inclined to plump for an airlock being the best first port of call.
  2. If the matrix had a small leak it would indeed explain the drip-drip loss of coolant. What it wouldn't explain is why the heating isn't working after replenishing the coolant. Like I say, I'll worry about the source of the leak after I cure my immediate concern re: chilly driving conditions. :)
  3. Hi there.. I'll worry next why the coolant level dropped 2 litres of fluid over the last six months - the immediate concern though has to do with curing a suspected airlock preventing the heating system working. Even though I've topped up the coolant. The 'net throws up solutions involving running the engine until hot with the coolant cap off + turning the heating dial to hot + squeezing the "top" hose repeatedly to shift the airlock But which hose(s) do they mean? The engine coolant circuit hoses get hot but the hoses to the heating valve and beyond into the car remain cold. It's low mileage '96 1.3l model Thanks in advance iano