AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


angelicshetan

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About angelicshetan

  • Rank
    Newbie

Profile Information

  • Ford Model fushion2/mondeo lx mk5
  1. quickclear not so quick!

    thank you to everyone who posted a response. i have checked the fuse and circuits which are fine. as there was already a small crack on the windscreen - which didn't effect road safety- i should be able to get it replaced. when i purchased joey (so called because of the plate), the crack was inspected by autoglass and told to leave it until it got bigger and to then replace it thanks again...
  2. quickclear not so quick!

    thanks for letting me know sobaka. i'll pass the info on, although i think there might be a six year warranty on the mondeo as it was a ford direct car. i might be mistaken - my dad knows. as it is, i guess it'll be £60 excess....for a new windscreen. i love my car and i begged for a year to have one but do wonder if it was worth it since the car pops out of reverse and dealership couldn't do anything to sort it.....and now this...i guess these things are sent to try us!
  3. quickclear not so quick!

    do you know if ford have done anything to resolve this problem as if what you say is true, then it seems to be a manufacturing fault. surely its up to ford to replace the windscreens in these cars?
  4. this is my first post and i apologise if this topic has been addressed before but i couldn't find the answer to my problem while browsing so thought i'd post. my dad has an '03 mondeo lx and i have a '53 fushion 2 with the same problem. we both find that our windscreens do not clear fully when using the quickclear button. although the problem is slight in the mondeo (two vertical strips about 5mm wide on the passenger side) its much worse on my fushion, where only half the screen clears (on driver's side). it takes 3 attempts to clear and even then it tends to leave stripes. has anyone else had this problem and is there a solution? i don't want to have to take it to ford unless there really isn't another option. please help!