Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


darren51274

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About darren51274

  • Rank
    Newbie

Contact Methods

  • First Name
    Darren

Profile Information

  • Gender*
    Male
  • Ford Model
    fiesta zetec s
  • Ford Year
    2010
  • UK/Ireland Location
    Essex
  • Annual Mileage
    5001 to 10,000
  1. Sounds like there is air in the fuel system,If was fine before filter changed would guess there is a leak/pipe not on filter fully. Go back to garage and get them to check it..
  2. Cheap maf sensors dont tend to work very well.For some reason they work better on some cars than others but cant be relied upon.. Egr valves can cause rough running and loss of power and not uncommon to go wrong. If its suddenly got very bad after you sprayed the maf sensor i think you just may have added to your problems...Can you borrow one from someone else for testing???
  3. Hi, yes the flat battery does sometimes cause the error message on the dash. i had a battery on my focus that would just about still start the car but would give that message on the dash when it started. new battery and all was fine.
  4. Well at least its not just my car then. Makes me feel a bit better about it. Would be nice to find a cure for it though..
  5. Hi, Does anyone else have a problem with the foot brake having excessive pedal travel before the brakes do anything? Brakes work fine just the amount of travel in pedal. Any ideas?? brakes have been adjusted and inspected and all ok..
  6. Welcome to the Ford forums darren51274 :)