AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


chrisrigby

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About chrisrigby

  • Rank
    Newbie

Contact Methods

  • First Name
    chris

Profile Information

  • Gender*
    Male
  • Ford Model
    Focus 1.8TDi
  • Ford Year
    2003
  • UK/Ireland Location
    London
  • Annual Mileage
    0 to 5000
  1. Thanks for all the responses so far, but the main element that seems to determine if the speedo works is the outside temperature. When it's warm it works perfectly, when it's cold it does not. Rain does not effect it. It has had a new VSS and a new instrument cluster. Maybe there is an auto electrician out there who has come across this problem before. Also, any Ford people who may be able to confirm whether there is a chance I have had a dodgy cluster fitted. Has anyone come across this? Thanks again to all that have responded so far. I refuse to be beaten on this one.
  2. Replaced with a Bosch S3 100 (70ah).
  3. OK, here is the issue. Ford Focus 1.8TDi on a 53 plate in the UK (2003 model). Battery was on the way out, so replaced. Just after that the speedo stopped working. Assumed the VSS, so replaced it, but problem still there. The weird thing is, the speedo works fine if the outside temperature is above circa 20 degrees, but does not work if the temperature is below this. When the temperature is below this it works sometimes, but mostly not. When the speedo is not working the car does idle higher between gear changes, though I assume this is because the cluster is not getting any speed information. Returns to normal when the speedo starts working again. Also, as I drive along, if I switch off the ignition and then switch it back on again, the speedo starts to work, but very erratically. Bad earth maybe? Car also recently had a new cluster, so assume that not to be the problem. I am pretty technically minded, but not a trained mechanic, so please keep replies fairly simple. Any advice very much appreciated as I refuse to be beaten and think the whole outside temperature issue must be a big clue to someone out there with good technical knowledge. Thanks
  4. Welcome to the Ford forums chrisrigby :)