• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


jackd

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About jackd

  • Rank
    Newbie

Contact Methods

  • ICQ
    0

Profile Information

  • Gender*
    Male
  • Ford Model
    fiesta mk3.5 azura
  1. whisling sound

    could be a slack weather seal. where does the noise seem to come from?
  2. engine warning light

    sounds like cat might be the problem as if the cats not working it will damage the lambda sensor.
  3. xr2i overheating

    have a feel of your bottom hose coming off rad if this is cold and top hose heats up your radiators probably blocked.
  4. good to see another mk3 driver ere, hope u can get some pics up soon m8.

    CHRZ

  5. mk3 fuel pump problem

    cheers. have a 2i pump thtl fit straight in so al jus pop tht in its place if i really need to.
  6. rev counter query

    im thinking about putting a set of xr2i clocks into my 1.1 azura but not sure how to feed tht rev counter to get a reading as the standard quages have no tacho. would i need a feed from the ignition coil or ecu??
  7. mk3 fuel pump problem

    just bought a mk3 fiesta. the fuel pump doesnt prime on ignition, unless i hit under the rear seats a little.told by a few mates who love their fords tht its quite common and he says that its the conections on the pump getting dirty. when ive cleaned them up does anyone know how to keep them protected. any advice apreciated