Jonny

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About Jonny

  • Rank
    Newbie

Profile Information

  • Ford Model
    Focus
  1. Hi. I posted a while back as I thought my Alternator was on the way out. 2Ltr TDCI 05 plate @54000Miles. Sure enough it was and I changed it without any issues. Three days later a mate of mine in his 54 plate C-Max 2Ltr TDCI@52000Miles said he thought the same was wrong with his alternator. Sure enough it was knackered. His got so hot it almost set on fire!!! Just wandering if there are any other alternator issues around the same miles? It was the 120Amp version not 150Amp. Cheers.
  2. Hi Boots, Nothing to worry about. Just stuck on due to the weather and lack of use.......Rusty. Will be fine after using the brakes a few times. Hope this helps.... :D
  3. Thanks for the reply. The belt is good and one of the first checks I carried out. Connections are good too. Called ford today for prices.....£100+vat. Good price :D. I THOUGHT IT WOULD BE ALOT MORE............. Cheers Jonny
  4. Hi All. Just after a bit of advice..... My 2ltr TDCI battery light came on last night along with a whining noise from the engine. Thought Alternator straight away. Checked battery charge from alternator via diagnostic page and it was only at 11.8V. Compared it with a mates this morning who's is at 14.4V. Car got to work ok but when it was time to come home......it struggled to start with central warning light flashing. ABS and ESP lights came on and no front screen heating. Got caught in a bit of traffic and lights switched off then on again. Radio went off and then came on again. Fun, Fun, Fun. So my thinking is that the whining is th brushes in the alternator worn so not charging and supplying juice to me motor!! Just wondered if anybody has had anything similar or if you are a car techie kow if my diagnosis it close. Cheers.... Newbie Jonny.