Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


Richard Harvey Howells

Members via FB
  • Content count

    6
  • Joined

  • Last visited

About Richard Harvey Howells

  • Rank
    Newbie
  1. Hi, Thanks for all the help! I have tested the plug and there is 12v coming through two of the connections relative to earth, but the light on the button still won't activate. Do you know which fuse/relay positions in the cabin and engine bay fuse boxes are needed, my manual doesn't tell me which fuses/relays are for the windscreen! I played around with the rear screen, and found which relay governed it. I took out the relay and the light on the button still worked, but the heated screen did not come on. The same cannot be said for the front windscreen, as neither the light on the button or the screen comes on when the button is pushed, so it is more than just a single missing relay i think? As for the radio, switching the yellow (battery) and red (12v switchable) meant the radio worked, but putting them back the other way also meant it worked for some reason? the radio would not turn on without the ignition in and twisted to the 1st position in either configuration, while the 6000CD used to... All I need now then is the aerial adapter and the remote adapter then I am sorted with the CD player hopefully :) I've had a look at the connections under the screen, Martin and stoney, and I cant see any damage to them. I understand that each half of the screen is separate and that they both earth on the drivers side pillar? Thank you again for the help! Rich
  2. Hi all, I recently bought a focus 1.6 TDCI 05 GHIA model, with automatic everything and its great! I do however have 2 small problems with it, and cant get on with them... NUMBER 1 I have bought an ALPINE CDE-W235BT and cannot fit it successfully to the focus. The fascia adapter I bought was about 2mm too small (despite being marked up as an 05 focus adapter) and although I have bought a wiring harness for the focus from halfords, when fitted the radio won't turn on. On top of that I apparently need a steering stalk controller adapter too, and the aerial adapter. With the silly number of websites selling many many adapters all for the same thing i cannot fathom what to do and so have come to here for help! Please can somebody tell me a shopping list of items i need, i will just return what i have bought already if it is wrong. OR, if somebody could tell me if this is the correct wiring for the focus, then i can get handy with the soldering iron... http://www.modifiedlife.com/2005-ford-focus-car-stereo-wiring-schematic/ NUMBER 2 The heated windscreen won't work. I have checked the fuses, and checked the wiring on the screen with a continuity tester and cant get it to turn on and heat. When I press the button to turn it on, even the LED light on the button won't turn on. the heated rear screen works so it can't be the timing module, but could it be the switch? other info, i am based in the UK, near uttoxeter at the moment, but am around the peterborough/stamford area often... Thanks so much for any replies in advance, i usually try not to use up people time on these forums, but i am at a loss as to what to do next... Rich
  3. I tried this and with the filter removed, and the cover on the side back on it works beautifully. off to halfords to get a replacement for 12 quid :) Thanks for all your help :) i will get the air con regassed by a garage, is 80 quid reasonable? he rekons he will pressurise it to check that the system is ok, then evacuate the old gas, then add some anti-mould chemical then add the gas, which sounds fishy to me as i have never heard of this anti mould thing before? my friend says he pays 50 quid, but that deosnt include he pressure check. if anyone else comes accross this thread, then the halfords ref for the pollen filter for an 05 focus is: Cat. code: 214580-0 Halfords Cabin Filter ACE158
  4. Brilliant! thanks a lot mintalkin, i will give this a crack tomorrow and see if it works. its so simple it might just work! (cant believe i didnt think of it before, i always try to overcomplicate things...)
  5. where can i find that? is is under the hood?
  6. Hello, i recently joined the ford owners club, buying a maroon 05 reg 1.6 TDCi focus Ghia, its brilliant! However, the air conditioning deos not cool at all, the light turns on and everything, so i think this just needs regassing? can i do this myself or is it best to go to a garage? THE MAIN PROBLEM is that the fans that blow air into the cabin are performing like asthmatic hamsters... They are working at about 1/4 of what they should, because i had a go in a friends focus CMAX and on setting 1 on his car the same airflow came out as 4 on mine. However on setting 4 on both cars the noise was the same, that is there was no extra crunching, squeaking, grinding, or anything to suggest the fan is hitting something or that the bearings have gone. furthermore, the fan works on settings 1 to 4, but at a quater of the capacity, so it is not the resistor pack, or the thermal resistor i dont think, ebcause then ONLY 4 would work? therefore, my only option is to check all the pipes are connected, in case the fan is blowing into a tube not connected to the rest, or if there is a hole in he pipes somewhere? any thoughts or suggestions would be great as to why this is happening... a breif summary of symptoms fan works on settings 1-4, at a about 1/4 power no noises to suggest bearings etc are faulty, all noises are normal A/C deos not work, though this may be a separate issue Also, my engine has NO issues with cooling, it runs at a very happy temperature and is not overheating in the slightest, even when stationary. Thanks Richard
  7. Welcome to the Ford forums Richard Harvey Howells :)