AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


The Gardener

Budding Enthusiast
  • Content count

    18
  • Joined

  • Last visited

About The Gardener

  • Rank
    Member
  • Birthday 05/25/1960

Contact Methods

  • ICQ 0

Profile Information

  • Gender* Male
  • Ford Model mondeo mk3 petrol estate 1.8 (x reg)
  1. Mondeo misfiring at low revs

    I had same problem which turned out to be the coil pack. My friendly local moto shop let me borrow ht leads and as this made no difference i put in new plugs still making no difference. Then a banger racing friend of mine suggested the coil pack, 'about £50 off e/bay' and after fitting, this cured the problem. Hope this helps Simon
  2. ALARM HORN LOCATION?

    Hi! Can any one tell me the location of the alarm horn on my mk3 'x reg' mondeo please? (I,de like to replace the horn with something louder) I thought it was linked to the main horn but it isn,t? It has just the standard factory fitted alarm system. Cheers.
  3. Engine number

    Not sure about engine number but chassis number is just below windscreen washers under bonnet looking straight ahead. Hope this helps.
  4. sudden increse in high revs?

    Problem solved! Sticking throttle cable. Also changed coil pack and solved problem with jerky acceleration. Cheers All!
  5. sudden increse in high revs?

    Thanks for the reply! Iv,e checked throttle linkage etc and all is ok. Also when the revs suddenly shoot up i notice that the accelerator pedal becomes stiff, heavy? Could the throttle cable be getting snagged, frayed? One other syptom i didn,t mention was jerky acceleration and was told this was the coil pack, i,m fitting a new one tomorrow, could this be related to high revs i wonder? Simon
  6. sudden increse in high revs?

    Can any one help with this problem? Driving home tonight in my mk 3 '1.8 Mondeo petrol' manual x reg, i had the fright of my life when changing from 2nd to 3rd gear, as the revs leapt up to 6000rpm even though my foot was off the accelerator pedal? The high revs lasted for about 4 seconds. It did this every time i changed gear but i was able to crawl home using small amounts of throttle. I checked under the bonnet when i got home and revved the car up in neutral and it seemed fine? It,s not the clutch as the car stalls when handbrake is on in 1st gear as i attempt to move. Any help would be welcome. Simon
  7. Mondeo back box

    Petrol 1.8 (x reg) Thanks
  8. Mondeo back box

    Hi All! I have the mk3 mondeo estate 2000 reg. The back box is blowing, am i right in saying that you can not buy just the backbox but need to buy the mid section/backbox as a complete unit? Cheers! Simon
  9. Sun Roof Problem

    Many thanks! I shall check motor asap.
  10. Sun Roof Problem

    Hi All! The problem i have with the sunroof on my mondeo is that when you press the switch all i get is lots of loud clicking and no movement from the sunroof? Any Ideas?
  11. 06 duratec 1.8 125hp

    No idea what the fault code was, all i did was remove the back box and after finding this was the fault i replaced the old box with new. Simon
  12. 06 duratec 1.8 125hp

    Hi! I had a cavelier a few years back with very similar problems. It turned out to be the exhaust back box disentigrating and stopping gases from being released. I removed the box before buying a new one, started the car and drove loudly for a few miles and all was well! You never know, this may be your problem. Simon
  13. Owners Manual Needed

    Hi! What year is your Mondeo? as i might have what you need.
  14. mk3 mondeo heater control air con problem?

    Sorted! I replaced the heater control unit (£10 from local scrappy} and everything works! :P :P
  15. Hi All! My mk 3, year 2000 mondeo heater control switch is playing up? The blower control Knob works as normal blowing slow or fast, but the other 2 dials 'Hot and Cold' dial, and vent control dial don,t do anything at all? Also the air con switch and the recirculating air switch do nothing? 'No illumination' Iv,e checked all fuses and they are all ok? The vent is stuck on the windscreen at the moment and the heat control is stuck on hot 'Phew!!' :o Any Ideas would be appreciated! Simon