Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


DannoUK

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About DannoUK

  • Rank
    Newbie

Contact Methods

  • First Name Dan

Profile Information

  • Gender* Male
  • Ford Model Ford Focus 1.6 TDCI Titanium 110
  • Ford Year 2009
  • UK/Ireland Location Norfolk
  • Annual Mileage 5001 to 10,000
  • Interests Computers & Electronics
  1. Travelpilot Fx Updates

    Hi, I have a 2009 Ford Focus 1.6TDCi Titanium which has the TravelPilot FX navigation system installed. Currently I have the 2009 maps on a BLUE SD card. I know there are 2 versions of this unit, one taking a BLUE SD card and the newer one a YELLOW SD Card. I am also aware that there is a 2011 YELLOW Card available which is not compatible with my system. I can't seem to find anything other than a 2010 BLUE SD Card on eBay. Does anyone know what the latest map version is for this unit? Regards Dan
  2. Hi, I recently bought a 2009 Ford Focus Titanium 1.6TDCi which what I believe is the Travelpilot FX headunit. I have recently been having intermittant problems with the stereo that i'm hoping some of you may have seen. When i bought the car, the first issue i found was no right audio from my Ipod, USB stick or Aux device. 3 trips to the Ford dealer and they changed the Bluetooth device (the Aux and USB ports are part of the Bluetooth kit apparently). All was well for a few days - then the fun began. I have been experiencing the following intermittant problems: * Headunit locked up after hanging up a call received through the bluetooth kit. The RADIO, CD/AUX/USB buttons dont work at all and no sound heard from the stereo. The PHONE button works but cant hear any sound on calls. The NAV and MAPS screen functioning fine. Seems to be just the audio side of things that have frozen. The only way to resolve the problem is to turn the engine off, lock the car, and leave for 10mins. Sometimes a constant humming/buzzing noise can be heard from the area of the headunit/bluetooth device. * Happily driving about with my Pure Highway DAB unit plugged into the AUX port working fine. I pop in a shop for a min, come back out, start the engine and the stereo locks up with tth same symptoms as above. * Get in the car, turn on the stereo, select USB (i have a USB stick full of music) then same thing happens as above. Since these issues, i have upgraded the firmware to the latest on fords website hoping this might help - it does not. Now my USB stick isn't recognised at all even though its formatted to exFAT as its 64GB. Any views or ideas guys? I have a couple of months left of the warranty left on the car but have a feeling Ford wont find the issue as its fairly intermittant. Regards Dan
  3. Welcome to the Ford forums DannoUK :)