Ian1211

New Member
  • Content count

    1
  • Joined

  • Last visited

About Ian1211

  • Rank
    Newbie

Profile Information

  • Ford Model
    focus 1.8 tddi 90 bhp
  • UK/Ireland Location
    Surrey
  1. I own a y reg 1.8 TDDI focus 90bhp when I brought her she was fine but in need of a service and while I was there as there was no service history I got a new cambelt/timing kit put on then 2 days later my diesel pump failed (bad luck eh) I put on a reconditioned bosh pump with a new brain on it from PB Asher and it was fitted by First Diesel in Croydon (25 yrs experience!) but since it was fitted it no longer had a smooth idle but drove well throughout the rev range. I gave it back to First Diesel as I wasnt happy and they 1) checked the old pump in case it had any metal in it - it was clear 2) take out the injectors and clean them - they did this twice 3) re-checked the job and ensure eberything was as it should be. All to no avail the problem still happens the weired thing is if I put the aircon on the idle smooths out and it sounds fine??? The alternator recently failed as well so I have just fitted another unit but this has not changed the bad idle. Before any of this work was done the car had a full service all filters including the diesel filter was changed the bad idle problem only happened after the new pump was fitted - the new pump was checked by First diesel with no fault codes recorded. They said it might be the injectors or an electrical fault but they are not really sure as the injectors are 2 stage and they are only abl to check the first stage - if it was the injectors surely turning on the aircon would not alter the idle? It reacts exactly to turning the aircon on or off to good/bad idle - has anyone suffered with this problem before it cant be an isolated case surely - any ideas as I dont want to keep chucking money at the car it getting too expensive!!. HELP PLEASE.
  2. Welcome to the Ford forums Ian1211 :)