AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About astonnick

  • Rank
  • Birthday 01/16/1994

Profile Information

  • Gender*
  • Ford Model
    Focus Zetec 1.6 TDCi
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    10,001 to 15,000
  • Interests
    General Automotive
    Motorsport & Racing
    Car Modification
    Computers & Electronics

Previous Fields

  • Location
    Ashford, Kent
  1. Na left that off, assume that's whats causing the noise although I'm learning to quite like it now :) I'll see what I can do Lenny
  2. Have been debating whether to get a K&N filter for a while, and after reading this decided to just bite the bullet and do it. Bought a 57S-4000 with new airbox lid ( and fitted it this morning. Haven't really tested it properly yet, but have driven up and down the road a full times and so far the throttle is certainly more responsive, and it makes a very loud whooshing noise on acceleration which I can't tell if it's cool or annoying yet haha.
  3. Not sure about the clutch, but the speedo/stalling issue is very common on the MK1 and MK1.5 such as yours. If I remember correctly, it's a faulty speed sensor that causes it. Not too expensive (, and I think you can fit it yourself but don't quote me on it.
  4. Yeah that's what I read somewhere, but couldn't for the life of me get it out. Pushing the screwdriver in just broke the clip, and no amout of wiggling seemed to help unfortunately. Thanks for the info though, might give it another bash tomorrow!
  5. I tried to change mine but could never get the !Removed! bulb holders out :( Managed to prize both lights from the boot lid a fair way, but never enough to get the original bulbs out. Had to give up in the end.
  6. Easiest just to remove the front panels. Gently prize open a gap with a screwdriver (or something else flat) and just give them a good pull. Changed both my fog lights in 10 minutes.
  7. Sorry if this sounds stupid, but how did you remove the trim piece covering the windscreen column? And how did you get the wire from the radio to the top of the dash? I'm crap at this as you can tell :)
  8. Where abouts did you put the GPS antenna?
  9. Had this on my old MK1. Sold it in the end, but I hear all you need is a new speed sensor. The speedo used to die on mine, often followed by the car stalling.
  10. Cheers for that :)
  11. I was looking at getting that... where did you put the GPS antenna?
  12. Welcome to the Ford forums astonnick :)